Change in batch job times seen between Controller 8.x and 10.x

Technote (troubleshooting)


Problem(Abstract)

User clicks "Maintain - Batch Queue - View". User looks at the times of the jobs (e.g. start / end times).

The values seem different when comparing a system based on Controller 8.x with one based on Controller 10.x.

Symptom

In older (Controller 8.5.x) versions, the times seen inside the 'Batch Queue' varied depending on the client PC's time zone. From Controller 10.x onwards, they no longer vary depending on the client device's time zone.

Cause

Code change in Controller 10.1 onwards.

  • TIP: This was done to stop problems like the one described inside separate IBM Technote #1370743.

More Information:
Controller 8.x:
The values of the various times shown inside " View Batch Queue" comes from the following places:
  • Started - the time according to the database server (e.g. SQL server)
  • Ended - the time according to the database server (e.g. SQL server)
  • Reg Time - the time according to the end user's client device (e.g. client PC's) clock
  • Scheduled Time - the time according to the end user's client device (e.g. client PC's) clock

Controller 10.x onwards:
When a job is created with the "Perform This Job" setting set to be " Execute Immediately" then the values shown inside "View Batch Queue" comes from the following places:
  • Started - the time according to the Controller database server
  • Ended - the time according to the Controller database server
  • Reg Time - Time as seen in the 'Schedule job' at area of the Schedule Job dialog (according to the client machine of the user creating the batch job)
  • Scheduled Time - the time according to the Controller application server

When a job is created with the "Perform This Job" setting set to be " One Time Only" then the values shown inside "View Batch Queue" comes from the following places:
  • Started - the time according to the Controller application server
  • Ended - the time according to the Controller application server
  • Reg Time - Time as seen in the Schedule job at area of the Schedule Job dialog (according to the client machine of the user creating the batch job) job.
  • Scheduled Time - Time as seen in the Schedule job at area of the Schedule Job dialog (according to the client machine of the user creating the batch job).

Resolving the problem

The change is by design.

Related information

1370743 - Batch queue - time delay for the continental

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Document information


More support for:

Cognos Controller
Controller

Software version:

8.3, 8.4, 8.5, 8.5.1, 10.1

Operating system(s):

Windows

Reference #:

1590788

Modified date:

2013-06-27

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