IBM Support

Change in batch job times seen from Controller 10 onwards (compared to Controller 8.x)

Troubleshooting


Problem

User clicks "Maintain - Batch Queue - View". User looks at the times of the jobs (e.g. start / end times). The values seem different when comparing a system based on Controller 8.x with one based on Controller 10.1 or later.

Symptom

In older (Controller 8.5.x) versions, the times seen inside the 'Batch Queue'...


...varied depending on the client PC's time zone.

From Controller 10.x onwards, the times shown no longer vary depending on the client device's time zone.

  • In other words, all users (whatever their own personal time zone) will always see the same values of the times (inside this screen)

Specifically, most times (except sometimes Registered time - see below) are based on the clock / time-zone of the servers (not of the end user's own personal time zone).

Cause

Code change in Controller 10.1 onwards.

  • TIP: This was done to stop problems like the one described inside separate IBM Technote #1370743.

More Information:
In the old Controller 8.x software, the values of the various times shown inside "View Batch Queue" comes from the following places:
  • Started - the time according to the database server (e.g. SQL server)
  • Ended - the time according to the database server (e.g. SQL server)
  • Reg Time - the time according to the end user's client device (e.g. client PC's) clock
  • Scheduled Time - the time according to the end user's client device (e.g. client PC's) clock.

Resolving The Problem

In modern (version 10.1 onwards) versions of Controller, the following is true:

When a job is created with the "Perform This Job" setting set to be "Execute Immediately" then the values shown inside "View Batch Queue" comes from the following places:

  • Started - the time according to the Controller database server
  • Ended - the time according to the Controller database server
  • Reg Time - Time as seen in the 'Schedule job' at area of the Schedule Job dialogue box (according to the client machine of the user creating the batch job)
  • Scheduled Time - the time according to the Controller application server

When a job is created with the "Perform This Job" setting set to be "One Time Only" then the values shown inside "View Batch Queue" comes from the following places:
  • Started - the time according to the Controller application server
  • Ended - the time according to the Controller application server
  • Reg Time - Time as seen in the Schedule job at area of the Schedule Job dialogue box (according to the client machine of the user creating the batch job).
  • Scheduled Time - the time according to the Controller application server

Example:
Imagine a scenario where:
  • Customer using Controller 10.x
  • Application and database servers located in London (Greenwich Mean Time)
  • End user located in Paris (Central European Time)
  • Current time in London = 12:00 midday
  • Current time in Paris = 1pm = 13:00

If the Paris user schedules a batch job to run at 13:01...

...then the job will NOT run 1 minute in the future.
  • Instead, this job will run 61 minutes in the future.
  • This is because the job has actually been scheduled to run at 13:01 (1:01pm) according to the clock in London.

======================================
This means that end users should schedule jobs based on the clock of the server (not the clock of their own client device).
======================================

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Document Information

Modified date:
15 June 2018

UID

swg21590788