IBM Support

Resynching ISM Profiles

Question & Answer


Question

In the ISM Configuration GUI in the TEP, you observe the status message 'Out of Sync'. What action is this message asking you to perform?

Cause

The ISM agent detected discrepancies between the ISM profile definitions on the agent compared to the same profile definitions in the KIS tables on the TEPS database.

Answer


When you open the ISM Configuration GUI in the TEP, you may notice the message Out of Sync in the Status column for one or more agents.

This message indicates that the ISM agent detected discrepancies in the ISM profiles. The agent compared the ISM profile definitions on the TEPS database and the active ISM profile XML files in the ISMHOME\profiles\active directory on the agent.



To resync the profiles on the agent, select the agent. The Resync Agent button is enabled. Click the Resync Agent button. The following message pops up. Click Yes.

Resynchronizing the agent replaces the active profile XML files on that agent with the current definitions of those profiles on the TEPS database.



The agent status changes to OK. Click OK to close the ISM Configuration GUI.



Profiles can get out of sync, for example, if you manually edited the XML profile files on the agent, or if you created or modified ISM profiles by using the ismbatch utility. When you use the ismbatch utility to create and edit ISM profiles, the profiles are not written to the TEPS database. Because the ISM Configuration GUI only reads the profile definitions from the TEPS database, profiles that you create by using ismbatch are not available in the ISM Configuration GUI.

Please avoid using the ismbatch utility to create and edit ISM profiles. When you resync the agent, you lose the profiles that you created or edited by using the ismbatch utility.

Use the ismconfig utility to create, edit, and resynch ISM profiles. When you use ismconfig to create and edit ISM profiles, the profiles are written to the TEPS database. Consequently, these profiles are also available in the ISM Configuration GUI. When you use the ismconfig utility, you do not need to resync the agents.

You can also use the ismconfig utility to regenerate the ISM profiles on the TEPS database from the existing profile XML files. This process converts and preserves older profiles that you created by using the ismbatch utility.

Although the ismconfig utility is for users who prefer command line interfaces, you can use the ISM Configuration GUI in parallel with the ismconfig utility.

Note: The ISM agent is marked Out of Sync when you attempt a configuration action that fails. The most common cause is modifying the configuration of a profile while the agent where you have deployed the profile is currently offline. For example, configuring OID groups causes any offline agents to become out of sync, since OID group changes are deployed to every agent.

The ISM Configuration GUI has no direct access to the profile XML files, so any external changes made to these XML files are invisible to the ISM Configuration GUI. Even though the ISM Configuration GUI thinks the agent has the correct configuration, the agent might not have the correct profiles -- if the profiles have been edited from outside of the ITM-based tools. This leads to the agent being marked out of sync later due to the local changes conflicting with updates the GUI is attempting to make.

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Product Synonym

ITCAMfT;T7.4;ISM 7.4;ISM

Document Information

Modified date:
17 June 2018

UID

swg21590452