Troubleshooting
Problem
This technote explains how to troubleshoot a Publish failed error message when you are publishing many IBM Cognos Insight workspaces.
Symptom
You receive the following error message when you try to publish a Cognos Insight workspace:
- Publish failed:
Failed to create TM1 Planning Application.
Publish is not allowed at this time. Publish may be disabled or this server or system resources may not be available.
Cause
By default, Cognos Insight will not publish if more than 10 Cognos TM1 servers are running at once. This configuration prevents users from overloading the system resources.
Resolving The Problem
You can resolve this issue by increasing the default publishing limits that are set in a Cognos TM1 configuration file:
- Stop the TM1 Application Server using the IBM Cognos Configuration tool.
- Open the following configuration file in a text editor:
install_location\webapps\pmpsvc\WEB-INF\configuration\fpmsvc_config.xml - Add the insight_publish and system_requirements elements in the following locations:
<?xml version="1.0" encoding="UTF-8"?>
<fpm_config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="fpmsvc_config.xsd">
<service forceQualifiedPaths="true">
<businessViewpoint enabled="false" uri="http://localhost:9410/bv
"/> - If necessary, modify the values of the following attributes in the system_requirements element:
- maximumTM1ServersAllowed
- minimumFreeDiskSpaceMbRequired
- minimumFreeMemoryMbRequired
- Start the TM1 Application Server using IBM Cognos Configuration.
[{"Product":{"code":"SSVJ22","label":"Cognos Insight"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21590313