IBM Support

TM1 10.1: Unable to start the Admin Server

Troubleshooting


Problem

Service will not start when attempting to start the TM1 Admin Server either as a Local System user or as a Domain Account in the Services tab or via Cognos Configuration

Symptom

Error Message: The TM1 Admin Server service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.

Cause

Not enough Permissions to start the Admin Server

Environment

TM1 10.1 and Windows Server 2008 R2

Resolving The Problem

The TM1 10.1 install must be completed by right clicking on the issetup.exe and selecting the option "Run as Administrator" on Windows Server 2008 R2. If this has not been done, an uninstall/reinstall would be required following these instructions to resolve this error.


There may be different causes for the same error message. It could also be related to a new server TM1 instance being created with a dependency on the Admin Service whereas the samples do not have this dependency. Fix is to remove dependency from newly created service instance - using regedit - reboot - and then it should work fine.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.0","Edition":"All Editions;Enterprise","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21589868