Technote (troubleshooting)
Problem
In WebSphere Portal v7, you may find that portlet preferences and configuration changes do not replicate or synchronize across nodes and cluster members in your cluster.
Symptom
You may not see any exceptions in the logs related to this, but a typical use case would be:
- Log in to Portal on Node 1
- Edit a portlet and change the preferences (for example edit the Bookmarks portlet and add a new bookmark)
- Log out of Node 1
- Log in to Node 2
- The changes you made to the portlet do not show up on this node.
A restart of Node 2 allows the changes to appear.
Cause
The first-level cached data is not being cleared in a timely manner in the WebSphere Portal JVMs. This has been identified as a product defect under APAR PM57478. It is scheduled for inclusion in WebSphere Portal 7001/7002 cumulative fix 13.
Resolving the problem
To workaround the issue, you can do the following:
1. Log in to your Deployment Manager.
2. Navigate to Resources -> Resource Environment Providers -> WP CacheManagerService -> Custom Properties
3. Add these properties:
cacheinstance.com.ibm.wps.pe.portletentity.firstLevelCacheSize=0
cacheinstance.com.ibm.wps.pe.portletentitycounter.firstLevelCacheSize=0
cacheinstance.com.ibm.wps.pe.portletregistry.firstLevelCacheSize=0
cacheinstance.com.ibm.wps.pe.portletmodel.portletdefinition.firstLevelCacheSize=0
4. Save changes and synchronize the nodes.
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