IBM Support

XML parser limits exceeded even though the message size is smaller than the XML parser limit set

Troubleshooting


Problem

I am using a Binary Transform action to transform a message on the IBM WebSphere DataPower SOA Appliance. The expected output of the transform is less than that of the XML Parser limit. However, when the probe is enabled, I get an error indicating the XML parser limits have been exceeded. Why is this happening?

Symptom

Error messages similar to the ones below may be seen in the logs when the probe is enabled.

xmlfirewall (Test_XMLFW): XML parser limits exceeded

xmlfirewall (Test_XMLFW): document size limit of 4194304 bytes exceeded, aborting

Cause

The probe has been designed to encode the output context of the Binary Transform action. The encoding and other processing that may be done by the probe can cause the data to grow slightly more than double the size of the expected output.

For example, if the output of the Binary Transform action is about 2 MB, once this is encoded and processed by the probe, the size of the data will grow to a value slightly more than double the 2 MB and this will cause the default parser limit (4 MB) to get hit of that is the limit being used.

Resolving The Problem

Disable the probe or increase the XML Parser Limits on the XML Manager attached to the service.

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Document Information

Modified date:
15 June 2018

UID

swg21588939