"An error occurred while retrieving content" displays in the reports portlets

Technote (troubleshooting)


Problem(Abstract)

"An error occurred while retrieving content" displays in the reports portlets of the IBM Work Optimization for Water Utilities user interface.

Symptom

The error only occurs when IBM Work Optimization for Water Utilities v1.0 Fix Pack 1 (1.0.0.1) is installed on top of an environment that is running IBM Intelligent Operations Center Version 1.0 Fix Pack 1.


Cause

This issue is caused if Tivoli Enterprise Monitoring Agents for Web Services are running on the IBM Intelligent Operations Center analytic server. IBM Cognos Business Intelligence on the analytic server provides the reporting feature of IBM Work Optimization for Water Utilities. When Web Service monitoring is enabled, the Cognos requests cannot be processed, resulting in the error in the reports portlets.

After installing the IBM Intelligent Operations Center Version 1.0 Fix Pack 1, the Tivoli Enterprise Monitoring Agents are installed and running on each of the IBM Intelligent Operations Center servers. By default, the Tivoli Enterprise Monitoring server enables Web Service monitoring on the Websphere server instance running on the IBM Intelligent Operations Center analytic server. This was not the case in earlier fix packs for the solution. If Web Service monitoring is enabled, the Cognos dispatcher fails to process the Cognos SOAP request and returns a failure.


Resolving the problem

This issue has been reported to IBM Quality Engineering and a fix is under investigation.


You can work around this issue by disabling the Tivoli Enterprise Monitoring Agents for Web Services on the IBM Intelligent Operations Center analytic server. The following procedure explains how to do this.

  1. Log on to the IBM Intelligent Operations Center analytic server as the root user.
  2. Edit the Cognos Gateway datacollector.properties configuration file in the following directory:

    /opt/IBM/ITM/lx8266/yn/wasdc/7.1/runtime/was70.CognosNode01.CognosX_GW/

    Add the following line to the end of the file: ws.instrument=false
  3. Edit the Cognos Dispatcher datacollector.properties configuration file in the following directory:

    /opt/IBM/ITM/lx8266/yn/wasdc/7.1/runtime/was70.CognosNode01.CognosX_Disp/

    Add the following line to the end of the file: ws.instrument=false
  4. Initialize the Cognos environment variables and Java path by running the command:

    source /etc/bashrc
  5. Restart Cognos by running the following commands:

    /opt/ibm/cognos/c10_64/bin64/cogconfig.sh -stop
    /opt/ibm/cognos/c10_64/bin64/cogconfig.sh -s

  6. Open the directory of Cognos Application Server:

    cd /opt/IBM/WebSphere/AppServer/profiles/CognosAppSrv01/bin

  7. Stop the Cognos Dispatcher service using the command, replacing the WebSphere_administrator and WebSphere_administrator_password variables with the correct values for your server:


    stopServer.sh CognosX_Disp -username WebSphere_administrator -password WebSphere_administrator_password

  8. Stop the Cognos Gateway service using the command, replacing the WebSphere_administrator and WebSphere_administrator_password variables with the correct values for your server:


    stopServer.sh CognosX_GW -username WebSphere_administrator -password WebSphere_administrator_password
     

  9. Start the Cognos Dispatcher service using the command:

    startServer.sh CognosX_Disp

  10. Start the Cognos Dispatcher service using the command:

    startServer.sh CognosX_GW

Related information

System configuration for the IBM Intelligent Operations
IBM Intelligent Operations Center fix pack server monit

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Document information


More support for:

IBM Intelligent Water
IBM Work Optimization for Water Utilities

Software version:

1.0.0

Operating system(s):

Linux Red Hat - xSeries

Reference #:

1588734

Modified date:

2012-10-11

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