IBM Support Assistant Lite Tool Data Collector for FileNet Process Engine fails with OutOfMemoryError message.

Technote (troubleshooting)


Problem(Abstract)

The IBM Support Assistant Lite Tool Data Collector for FileNet Process Engine returns "Timeout: Killed sub process The collection has ended due to an error"

Symptom

Data collection stops with the following message in the progress box.

Cause

There is not enough Java heap memory available to the data collection program.

Environment

Solaris

Diagnosing the problem

Go to the ISALite/log directory and open the isalite-error0.xml and the isalite-trace0.xml. Search for the following exception:

java.lang.OutOfMemoryError: Java heap space.


Resolving the problem

The runISALite.sh and runISALite.bat contain the following code that requests memory from the Java Virtual Machine at startup.

"%JAVA_CMD%" %DEBUG_OPTS% -Xms64M -Xmx128M -cp

Increasing the values will allocate more memory which should allow the program to complete.


    1. Click the Quit button to close the ISA Lite Data Collector.

    2. Open the runISALite.sh (or runISALite.bat if running on Microsoft® Windows Server) in a text editor and change 64 to 128 and 128 to 256 as shown below.


      "%JAVA_CMD%" %DEBUG_OPTS% -Xms128M -Xmx256M -cp

    3. Save the changes.

    4. Execute the script again.

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Document information


More support for:

Case Foundation
Process Engine

Software version:

4.5.2.1, 4.5.2.3, 5.0

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Software edition:

All Editions

Reference #:

1588138

Modified date:

2013-05-14

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