Troubleshooting
Problem
After migrating to v7.1.x, synchronization between Rule Studio and Rule Team Server fails because the model extensions are not the same, even though the default model extensions are being used.
Symptom
The warning "Rule model extensions are different" is displayed when connecting Rule Studio to Rule Team Server:
Cause
The default extension file in Rule Studio has annotations for effectiveDate:
<property extractable="true" name="effectiveDate" type="Date">
<annotation id="validator-class"
value="ilog.rules.teamserver.web.validator.IlrComparablePropertyValidator" />
<annotation id="validator-compared-property" value="expirationDate" />
<annotation id="validator-constraint" value="LESSTHAN" />
</property>
In RTS, the default model extension does not have the above annotations : it is possible that when migrating to RTS V7.1.x, the model extension files were not updated.
However, since the Rule Studio model extension files were updated as expected, the synchronization with RTS fails.
Resolving The Problem
Update the model extensions in Rule Team Server:
- Navigate to the "Configure" tab and click on "Installation Manager" .
- Go to "Step 1: Configure Database".
- Under "Select the extension files you want to use:" choose "Custom extensions" and navigate to the default extensions used by Rule Studio, which can be found under <JRulesInstallDir>\studio\eclipse\plugins\ilog.rules.commonbrm.extension_7.1.1.4\resources\, if working with JRules v7.1.1.4.
- Select "Upload Only".
- Click on "Apply".
- This should take you to a "Processing" view, and then back to the "Configure Rule Team Server database" page with a message that says "Step execution successful".
- Click on "Exit".
This will upload the v7.1.x extensions, and you should be able to synchronize with Studio properly.
For any additional synchronization issues, please refer to this document.
Related Information
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21587770