IBM Support

Opening report in Excel link returns error "This file is not in a recognizable format' caused by defect PM45355 in Controller 10.1.0.

Troubleshooting


Problem

User launches Microsoft Excel. User clicks the Controller add-in (inside Excel) and logs onto Controller. User clicks "Controller - Reports" and then chooses "Open report". User selects a report. User receives an error message. User clicks OK but nothing happens.

Symptom

This file is not in a recognizable format.

Cause

There are many potential causes for this error.

  • For more examples, see separate IBM Technote #1647017.

This Technote specifically relates to the scenario where the cause is a code production problem (defect APAR PM45355) in Controller 10.1.0.

Resolving The Problem

Upgrade to Controller 10.1.1 (10.1.1305) or later.

Workaround

Instead of opening the report from Excel, open report from the 'main' Controller client (CCR.EXE).

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21586399