IBM Support

Unable to Filter Select Ordered Items Dialog Box

Question & Answer


Question

Is it possible to filter on the list in the "Select Ordered Items" dialog box in the Receiving application?

Cause

In version 6 clicking the filter link in the Select Ordered Items dialog box does not provide the fields for entering search criteria.
In version 7 the Filter link is grayed out.

Answer

In Maximo, a filter cannot be used on nonpersistent attributes. In the case of the "Select Ordered Items" dialog box, the entire object is nonpersistent. If the fields were able to be filtered, when you click on the "Filter"-in that blue line, if any fields were persistent, you'd get a blank box where you could put in a value to filter. Because all of those are nonpersistent, you will not get any blank boxes. In the case of the Select Ordered Items, the whole object is nonpersistent which is why you can't filter on any of the fields. The reason there is a filter included in the dialog box although it will never work is because all the dialog boxes come from the core XML's. The XML/JSPs will not be aware whether the fields in the dialog box are persistent or nonpersistent so the filter option is always shown.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Receipts","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5;6.2.1;6.2.2;6.2.3;6.2.4;6.2.5;6.2.6;6.2.7;6.2.8;7.1.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21585611