Troubleshooting
Problem
Workflow requests can remain in a pending state if one node in a cluster is not started.
Cause
A message is found to be sitting on the sharedWorkflowQueue. The message is for the request that was submitted and it's state is 'REMOTE LOCK'.
The message will stay in this state until the ITIM Application Server that was shutdown is restarted. Restart the node and that ITIM Application Server will process the workflow request and the request will eventually complete successfully.
Environment
Cluster install with at least 2 nodes in the ITIM Application Cluster.
Cluster server topology:
- ITIM_Application_Cluster
- node1_itim
- node2_itim
- ITIM_Messaging_Cluster
- node1_jms
- node2_jms
Resolving The Problem
The shared activation specifications created during the ITIM installation process for the shared queues (ITIMSharedWorkflowActivationSpec, ITIMPolicyAnalysisActivationSpec, and ITIMPolicySimulationActivationSpec) should all be updated to set a target, target type, and target significance. The activation specs for the non shared queues do not need to be updated.
Using the WebSphere Deployment Manager Console, navigate to Resources -> JMS -> Activation specifications and find the one for the shared workflow queue: ITIMSharedWorkflowActivationSpec.
There is a setting under 'Destination' for 'Target'. The installer leaves this field empty.
Set 'Target' to the name of the JMS cluster ('ITIM_Messaging_Cluster' for example) and make sure that 'Target Type' is set to 'Bus Member Name' and 'Target significance' is set to ''Preferred'.
Repeat for the other two shared queue activation specifications: ITIMPolicyAnalysisActivationSpec, and ITIMPolicySimulationActivationSpec
Save the WAS config, doing a full synchronization across all nodes and restart all ITIM Application Servers (to ensure the change went through).
Now when either one of the servers in the ITIM Application Cluster is shutdown, the workflow requests still get driven to completion (fail over occurs as expected).
Note: This solution works on all versions of WebSphere 7.0. WebSphere support has released APAR PM72688 in WebSphere 6.1.0.47. With the release of this APAR by WebSphere support, this solution will work for ITIM 5.0, 5.1 and ISIM 6.0, in both support WebSphere environments (WebSphere 6.1 and 7.0).
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Document Information
Modified date:
16 June 2018
UID
swg21585381