Custom business rules must be updated before upgrading Rational Focal Point

Flash (Alert)


Abstract

After you upgrade to the latest release of Rational Focal Point, for compatibility reasons, you must request the custom business rules from the IBM Rational Focal Point support team.
Only the common business rules are included in the installation.

The common business rules are ChoiceAttributeText, LinkByText, LinkInfo, LinkListAttributeSum, ListAttributeSum, MailImport, MatrixWriter, SetChoice, SumTimeGridRow, TimeGridIRR, TimeGridNPV, TrafficLight and XPathValueFetcher.

Content

Before you upgrade, obtain the new compiled version of the custom business rules from IBM Software Support.

You must provide your list of business rules to IBM Software Support.
To get the list, open Rational Focal Point, click Advanced > Business Rules and copy the details of the business rules and the version information.

To upgrade from version 6.5.1 of Rational Focal Point to version 6.5.1.1 of Rational Focal Point:

  1. Obtain the compiled version of custom business rules compiled from IBM Software support.
  2. Upgrade to Rational Focal Point version 6.5.1.1 using the IBM Installation Manager. For more information, see Upgrading from a release of version 6.5 topic in the help.
  3. Start Rational Focal Point. The following message is displayed: 
    Startup interrupted. To avoid data loss please follow the instructions below:
    These business rules need to be updated: Your list of custom Business Rules for example
    Business rule Mirror is of too low version: 3, required: 4
    1. Request updated/recompiled versions of these business rules from support
    2. Place the updated business rules in [war]/WEB-INF/expressions/
    3. Restart Rational Focal Point
4: Copy the compiled version of custom business rules that you obtained from IBM Software support in the <fpwar_deployed_in_server>/fp/WEB-INF/expressions/ location.
5: Start Rational Focal Point.

For all other upgrade paths to 6.5.1.1 or 6.5.2:

If you are upgrading from any other version of Rational Focal Point, you can avoid this message by copying the compiled version of custom business rule after the database upgrade.
  1. Obtain the compiled version of custom business rules from IBM Software support.
  2. Upgrade to Rational Focal Point version 6.5.1.1 or 6.5.2 using the IBM Installation Manager. For more information, see Upgrading from earlier version information in the help.
  3. Start Rational Focal Point. The message to update the database is displayed.
  4. Proceed with the database update and close Rational Focal Point.
  5. Copy the compiled version of custom business rules that you obtained from IBM Software support in the <fpwar_deployed_in_server>/fp/WEB-INF/expressions/ location.
  6. Start Rational Focal Point.

Product Alias/Synonym

RFP

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Focal Point
Business Rules

Software version:

6.5.1.1, 6.5.2

Operating system(s):

Linux, Solaris, Windows

Reference #:

1584721

Modified date:

2012-02-24

Translate my page

Machine Translation

Content navigation