Technote (troubleshooting)
Problem(Abstract)
You attempt to install a Fix Pack, but the operation fails during the PrereqCheckingAction command task.
Symptom
In the Fix Pack installation logs, you see the following error:
Install, com.ibm.ws.install.ismp.actions.PrereqCheckingAction, msg1, Prerequisite checking has failed. Click Back to select a different package, or Click Cancel to exit.
Failure messages are:
Unable to find IBM WebSphere Commerce at version that is greater than or equal to 7.0.0.0 and less than or equal to 7.0.0.5.
Unable to find IBM WebSphere Commerce at version that is greater than or equal to 7.0.0.0 and less than or equal to 7.0.0.5.
Unable to find IBM WebSphere Commerce at version that is greater than or equal to 7.0.0.0 and less than or equal to 7.0.0.5.
Cause
The wrong COMMERCE.product file is used under WC_installdir/instance_name/properties/version/COMMERCE.product
WC_profiledir/installedApps/cell_name/WCServer_enterprise_archive/properties/version/COMMERCE.product
Resolving the problem
Toolkit instructions:
If you are installing the WebSphere Commerce Developer Fix Pack in the toolkit environment, find the information in <id> tags in the COMMERCE.product file. This is what the information should look like:
<id>wc.toolkit.be</id>
The following example shows where it might appear in the file:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE product PUBLIC "productId" "dtd/product.dtd">
<product name="IBM WebSphere Commerce">
<id>wc.toolkit.be</id>
<version>7.0.0.0</version>
<build-info date="19/10/09" level="091013edev"/>
</product>
If the information in the <id> tags says something else, change it to <id>wc.toolkit.be</id>.
After you fix the WC_installdir/instance_name/properties/version/COMMERCE.product deploy the COMMERCE.product file from the Commerce installation directory into the EAR, to replace the corrupt file. Once you have that file updated, then you should retry the installation and it should pass the pre-req check error.
- - - -
Runtime instructions:
If you are installing the WebSphere Commerce Fix Pack in the runtime environment, find the information in <id> tags in the COMMERCE.product file. This is what the information should look like:
<id>wc.server.be</id>
The following example shows where it might appear in the file:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE product PUBLIC "productId" "dtd/product.dtd">
<product name="IBM WebSphere Commerce">
<id>wc.server.be</id>
<version>7.0.0.0</version>
<build-info date="19/10/09" level="091013edev"/>
</product>
If the information in the <id> tags says something else, change it to <id>wc.server.be</id>.
After you fix the WC_installdir/instance_name/properties/version/COMMERCE.product deploy the COMMERCE.product file from the Commerce installation directory into the EAR, to replace the corrupt file. Once you have that file updated, then you should retry the installation and it should pass the pre-req check error.
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.