Performance report timestamp wrong

Technote (troubleshooting)


Problem(Abstract)

The OMEGAMON z/VM performance reports and viewing reports from the portal show the time is 5 hours behind the "real" time.

Symptom

The timestamps in OMEGAMON z/VM reports are 5 hours behind the time they should be. For example, if an event happened at 11:30 AM Eastern time, the report shows it happened at 6:30 AM.


Cause

The OMEGAMON Linux agent runs as a guest on z/VM. The customer is in the Eastern US time zone, but has set the 'offset to GMT time' on z/VM to 0. Thus the time on z/VM was showing as GMT time (which is 5 hours later than Eastern time. However, the 'offset to GMT time' on the Linux machine was set to 5, which is correct for Eastern time.

The TOD clock of the z/VM system is what is placed in the DCSS. This does not factor in your timezone offset, but does factor in the epoch value for your LPAR, if you have set one. This is the value that is passed to the ITM infrastructure. The agent, that is running on the Linux guest, will take the timestamp from the DCSS and use it's offset (which is the Linux guest timezone offset) to arrive at the timestamp you see in the reports. Since the two offsets to GMT do not match, you see the 'adjusted' timestamp in the reports.


Diagnosing the problem

Use 'q timezone' to see what is set for the offset to GMT time.

Resolving the problem

The only way to correct this is to use GMT and correct timezone offset on your z/VM system.

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Document information


More support for:

Tivoli OMEGAMON XE for z/VM and Linux

Software version:

4.1.0, 4.2.0

Operating system(s):

Linux, z/VM

Reference #:

1580454

Modified date:

2013-01-14

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