IBM Support

Starting IBM Rational DOORS results in error "Cannot connect to server"

Troubleshooting


Problem

Attempts to start IBM Rational DOORS results in the error "Cannot connect to server 19353@IBM-A5A7N7VIQU0 Server not found".

Symptom

You can not start the Rational DOORS client.

The full error message is as follows:


"Cannot connect to server 19353@IBM-A5A7N7VQU0 Server not found"


image

Cause

The error may occur because the host name, database name, or database port has changed or the database service is not started.

Resolving The Problem

To resolve this problem:

  1. Confirm the database server port number and machine name or IP address

  2. Modify the registry keys to reflect the proper port number and DOORS server name or IP address.

If you do not have access to the registry you can use start DOORS using the command-line switch -data to point to the correct database


Disclaimer

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986


    1. Verify if you are using 32 bit or 64 bit machine
      • Windows OS 64 bit registry keys are located under

        HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telelogic

      • Windows OS 32 bit registry keys are located under

        HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic

    2. Go the following Registry keys
      • For client machines:
        HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS\9.5\Config
        or
        HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telelogic\DOORS\9.5\Config

      • For Servers
        HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\9.5\Config
        or
        HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telelogic\DOORS_Server\9.5\
        Config


    3. Update the registry information to match the installed product configuration for
      • DOORS Home

      • Server Data location

      • Port Number

      • Server Host Name

    4. Verify the DOORS database server service is started

    Below is a sample list of DOORS 9.5 client registry keys
    image





    Below is a list of DOORS 9.5 server registry keys
    image


[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;9.0;9.1;9.1.0.2;9.2;9.2.0.1;9.2.0.2;9.2.0.3;9.2.0.4;9.2.0.5;9.3;9.3.0.1;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.4;9.4.0.1;9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.1.2;9.5.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21580266