IBM Support

How to quickly solve a failing GTP occurring after some modifications in Development model

Technote (FAQ)


Question

In a Production environment, when a Contributor application that used to work is suddenly having its "Go to Production" failing, it may be necessary to quickly get the application back online in previous state before even knowing what is causing the problem. This document explains how to do this after getting the necessary elements that will be analyzed afterwards.

Problems may usually occur after somes changes made in the Development model (triggering RECONCILE or not). These changes may have been done through various operations like :
- Synchronize with Analyst after some changes in the library
- E.list modifications
- Access Tables modifications
- Import data
- Admin links
- Macro "Execute Analyst Macro" that could execute some A>C links (sending data from Analyst to Contributor).

One of the various possible errors is the following, displayed on screen at the end of the GTP wizard :
The Go To Production Process failed.
Unable to collect error information from the underlying component.

Or the GTP may complete successfully but the RECONCILE status may be "FAILED" or "CANCELLED" after this with various types of errors. Here are some keywords to cover some of these possible errors :
- Error executing J expression : 'ACE2_rc ACE2_xids ' ... (JCE error)
- Unable to reconcile ... Error (HRESULT -2147023170)
- There are 'n' e.List items that must be reconciled before they can be included in the selection. These are 'n' of the e.List items that are unreconciled: {guid id}{guid id}...

Cause

Various causes, mostly unknown until IBM Support or Development can thoroughly analyze the faulty application and reproduce the problem with customer data.

Answer

Before going further, make a backup of the current state, using different manners for more safety and also to cover all possible formats that could be asked by IBM Support or Development teams :

- Make a backup of the application database or schema.
- From the CAC (Contributor Administration Console) use menu "/Tools/Deployment->Export Model and Data" to export the model (Development and Production with data) and the related Analyst libraries too (there are usually two of them : one containing the cubes and e.list, and one containing the dimensions).
- In the CAC under "/Development/Application Maintenance/Application XML" save two XML files : one for Development model and one for Production model (but none of them contain any user data). These files may be useful to easily import and replace a "Development" model by using the "Upload a Development model" macro step. [Note that a "Production" model can also be imported into a Development model : this would be like clicking on "Reset Development to Production" button from the toolbar. See below]

Now, if the GTP fails because of a problem on RECONCILE, it can be worthy to try the Show Reconcilation Progress and Repair tool :
- Run epReconciliationProgress.exe from the /bin directory of IBM Cognos installation.
- Once in that tool, click the ellipsis button [...] to select the application, then click "Load" button to load the application.
- Then the top level e.list item is displayed : expand all E.list items and determine which ones are not totally in black.
- Make a screenshot showing the whole hierarchy, including the name of each e.list item and its corresponding GUID : this could also help Support or Development teams.
A black point means that the e.list is reconciled. If a point contains some yellow, this means this is not totally reconciled.
- Select the unreconciled items and try to "Repair" them, starting by the lowest levels.
If RECONCILE succeeds, then retry a GTP from the CAC. If it succeeds then the problem should be solved.

If unreconciled e.list nodes cannot be repaired, or if GTP still fails after a successful repair, or if RECONCILE was not the cause of the GTP failure, then apply the next step.

Now here is the simplest step to get the Development model back to the previous working state, which was the state of the last successful GTP :
from the CAC, select the faulty application and go to the toolbar on the top to click button called "Reset Development to Production".
This operation might take few minutes and cancels all modifications that was made in the Development model since the last successful GTP (neither the Production nor the Analyst libraries are impacted)
After this, the GTP should work again.

Once the situation is back to normal, the next step is to determine what modification caused the problem.
In that purpose it is necessary to import the Contributor application package into a test machine to perform some tests (using the Tools/Deployment/import menu from the CAC on this test machine).
From the working state, make slight changes, step-by-step, and GTP again. If problem occurs, then "Reset Development to Production" again, and try to make less changes and re-GTP until the exact change that caused the problem can be determined.
- If the problem is caused by an "import" operation : reduce the amount of data until you determine the faulty rows.
- If the problem is caused by an admin link or an Analyst A>C d-link : unmap some elements on some dimensions, maybe until the link fills only one cell (meaning only one element is selected by dimension), and try different elements combinations.
- If the problem is caused by modifications done in the Analyst libraries (changing dimensions order in a cube structure, deleting or adding or modifying elements, etc...) then it should be necessary to get back to a previous version of the libraries, so that to replay the modifications step-by-step, then synchronize, then GTP, then "Reset Dev to Prod" if GTP fails, then making less changes in the libraries, re-synchronize, re-GTP, etc... until the exact faulty modification is found.

There is still a possibility that making step-by-step changes allows all modifications to be finally accepted in Contributor ; this means that the problem was not due to a particular change, but most probably to an impossibility to make too many changes at one time.

Document information

More support for: Cognos Planning
Contributor

Software version: 8.3, 8.4, 8.4.1, 10.1, 10.1.1

Operating system(s): Windows

Software edition: All Editions

Reference #: 1579043

Modified date: 24 January 2012


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