ITCAM for J2EE WebLogic Data Collector Configuration Error

Technote (troubleshooting)


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Problem(Abstract)

CYJWLC003 Cannot connect to weblogic server,please make sure the server is running ,and check host/port parameters. If connecting to weblogic over SSL, please check SSL client CA trust keystore file , and client certification files/types/password also.

Symptom

CYJWLC003 Cannot connect to weblogic server when using the T3 protocol.


Cause

Wrong port was specified during the DC configuration step

Diagnosing the problem

Verify the correct admin port via the WebLogic server log:

<BEA-002613> <Channel "DefaultAdministration" is now listening on 95.56.0.30:7703 for protocols admin, ldaps, https.>
####<2012-01-10 0 h 01 EST> <Info> <Management> <wdappc11> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1326171714109> <BEA-141187> <Java system properties are defined as follows:
APPL_BASE_PATH = /var_app


Resolving the problem

A separate "Admin" port in the Weblogic configuration, port 7703 was defined here.
By definition this requires an SSL connection, ie. https://<server>:7703/console/login/LoginForm.jsp
to bring up the Admin console.
Specified the connection on this port using "t3s" one-way SSL as the protocol.

Product Alias/Synonym

ITCAM4J2EE tema

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Document information


More support for:

Tivoli Composite Application Manager for J2EE
ITCAM J2EE WEBLOGIC

Software version:

6.1

Operating system(s):

AIX, HP-UX, Linux, Solaris

Reference #:

1578726

Modified date:

2013-12-16

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