Connectivity issues between TBSM Data Server and Dashboard Server

Technote (troubleshooting)


Problem(Abstract)

Data Server failed to connect to the Dashboard Server after LDAP users being replicated into Object Server (OS) database.

Symptom

Edit Services tab is not displaying in TBSM


Cause

After the LDAP users replication, tipadmin user exists in both FileBased and OS Repository where duplication can be found in the TIPRealm causing the issue.

Diagnosing the problem

Following errors can be seen based in the respective log files:-

(a) in SystemErr.log

[2/15/12 11:49:18:866 SGT] 00000020 SystemErr R
com.micromuse.common.datasource.SQLDataSourceException: Could not
connect to databases: {jdbc:sybase:Tds:10.8.196.71:4100} as user tipadmin

[2/15/12 11:49:18:866 SGT] 00000020 SystemErr R Caused by:
com.micromuse.common.datasource.SQLDataSourceException: JDBC Connection
Pool could not connect to either data source.

(b) in SystemOut.log

[2/15/12 11:49:18:913 SGT] 00000020 LTPAServerObj E SECJ0369E: Authentication failed when using LTPA. The exception is <null>.

[2/15/12 11:49:18:913 SGT] 00000020 exception W
com.ibm.tivoli.tip.vmm4ncos.ObjectServerAdapter login
com.ibm.websphere.wim.exception.PasswordCheckFailedException: CWWIM4512E
The password match failed.

[2/15/12 11:49:18:913 SGT] 0000001d SystemOut O Thread[Thread-33,5,main]:
java.lang.NullPointerException

(c) in trace.log

[2/15/12 11:49:18:712 SGT] 00000023 SystemErr R Caused by: java.sql.SQLException: JZ00L: Login failed. Examine the SQLWarnings chained to this exception for the reason(s).


Reviewing wimconfig.xml obtained from Data Server will revealed the following:-

<config:realmConfiguration defaultRealm="TIPRealm">
<config:realms delimiter="/" name="TIPRealm" securityUse="active">
<config:participatingBaseEntries name="o=defaultWIMFileBasedRealm"/>
<config:participatingBaseEntries name="o=netcoolObjectServerRepository"/>
<config:uniqueUserIdMapping propertyForInput="uniqueName"
propertyForOutput="uniqueName"/>
<config:userSecurityNameMapping propertyForInput="principalName"
propertyForOutput="principalName"/>
<config:userDisplayNameMapping propertyForInput="principalName"
propertyForOutput="principalName"/>
<config:uniqueGroupIdMapping propertyForInput="uniqueName"
propertyForOutput="uniqueName"/>
<config:groupSecurityNameMapping propertyForInput="cn"
propertyForOutput="cn"/>
<config:groupDisplayNameMapping propertyForInput="cn"
propertyForOutput="cn"/>
</config:realms>
</config:realmConfiguration>

*** tipadmin exists in both FileBased and OS Repository, duplicated in TIPRealm. ***

Resolving the problem

The solution for the above is to remove tipadmin from OS manually and then have the Data Server restarted.

Tipadmin will be used between dashboard and data server to communicate authentication and stored in data server file based repository - fileRegistry.xml. If it is replicated into OS, it will cause duplicated id for the same tipadmin.

Another approach to this issue is to remove ObjectServer from data server federate repository, because data server does not perform user authentication using ObjectServer. You may proceed to do so by editing wimconfig.xml file and remove the following entry from TIPRealm:-

<config:participatingBaseEntriesname="o=netcoolObjectServerRepository"/>

For further inquiries / assistance, kindly contact IBM Support.

Product Alias/Synonym

TBSM

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Business Service Manager

Software version:

4.2, 4.2.1

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1577874

Modified date:

2014-05-19

Translate my page

Machine Translation

Content navigation