IBM Support

Configuring Cognos to Use an Oracle 11gR2 RAC Database using SCAN

Troubleshooting


Problem

An Oracle 11g Release2(11gR2) RAC implementation can be configured to use a Single Client Access Name (SCAN) listener instead of referring to multiple hostnames or IP addresses in the SQL*NET string. How do we configure Cognos Configuration to connect to a content store or audit database configured in this type of environment?

Cause

The SCAN configuration uses a '/' in the JDBC string that is used. We cannot use the standard Oracle configuration setting as it places a ':' between the port number and service name (ie. host:port:service_name)

Resolving The Problem

You need to use the Oracle database (Advanced) configuration and enter a valid user name and password for the schema. For the database specifier you use the following format:

SCANhost:port/service_name

ie. myscanhost.domain.com:1521/orclscan

For more information regarding Oracle 11g SCAN refer to the following Oracle documentation below.

Related Information

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21577855