InfoMan batch RFT not putting out data

Technote (troubleshooting)


Problem(Abstract)

Information Management for z/OS (InfoMan) batch Report Format Table (RFT) not producing data in the data set pointed to by the DDNAME specified in the JCL

Symptom

No data in the file associated with the DDNAME specified in the batch job.


Cause

Someone had changed the ISPF profile that the batch job uses so that it no longer automatically wrote the output produced by the RFT to the DDNAME that was specified in the batch JCL.

Diagnosing the problem

Logged onto a user ID that was able to access the ISPF profile used by the batch job. Used the PROFILE command to verify that the Profile option 5 "Standard report destination" -> option 3 DDNAME was setup to write to the BLGRPTS ddname specified in the batch job. BUT, option 1 "Session control defaults" -> option 32 "Standard report" to send the RFT output directly to the specified DDNAME by default was blank.

You can run SMF reports to try determine who modified the batch profile to prevent this happening in the future.


Resolving the problem

If PROFILE -> option 1 "Session control defaults" -> option 32 "Standard report" is blanks, the RFT output will not be automatically sent to the DDNAME specified in PROF -> option 5 "Standard report destination".

This issue was resolved by setting PROF -> option 1 "Session control defaults" -> option 32 "Standard report" to DDNAME, then saving the profile. After doing this the batch RFT was re-run and the desired output was sent to the DDNAME specified in the JCL.

Document information


More support for:

Tivoli Information Management for z/OS

Software version:

7.1

Operating system(s):

z/OS

Reference #:

1577666

Modified date:

2015-08-04

Translate my page

Content navigation