Spanish accents are not visible within reports Rational System Architect XT 11.4.1

Technote (troubleshooting)


Problem(Abstract)

Attempts to use Spanish accents displays strange characters when publishing reports in IBM Rational System Architect XT 11.4.1.

Symptom

Expected result: Spanish accents are correctly displayed in Report headers or columns names in Rational System Architect XT reports.

  • Actual result: Report headers or columns names showing strange characters instead of the accented letters when working with Spanish language in Rational System Architect XT.


Cause

Incorrect report encoding or incorrect encoding in the web.config file in System Architect XT.

Resolving the problem

To resolve the problem do the following:

  1. Open the report file from
    \Program Files\IBM\Rational\System Architect Suite\System Architect\SAXT Publisher\Reports\


  2. Save the file by File > Save As


  3. Select "ANSI" under "Encoding", and Save


  4. Open the web.config file
    \Program Files\IBM\Rational\System Architect Suite\SAXT\web.confg


  5. Set the value for the key="encoding" under <appsettings>
    <add key="Encoding" value="iso-8859-15"/>


  6. Save and close the file.


  7. Launch SA/XT in Reader mode and run the report.


  8. Check the accented letters are now displayed correctly.


  9. Launch SA/XT in Updater mode and run the report. They will also be displayed correctly in Updater mode.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational System Architect
General Information

Software version:

11.4.1

Operating system(s):

Windows

Reference #:

1577412

Modified date:

2013-06-10

Translate my page

Machine Translation

Content navigation