IBM Support

ACN0502E failure during a FlashCopy Manager backup

Troubleshooting


Problem

When using the Tivoli Storage FlashCopy Manager to backup an Exchange database, the operation fails with an ACN0520E error.

Symptom

The following error message will appear in the Tivoli Data Protection for Exchange log. By default, this is the tdpexc.log in the Data Protection for Exchange installation directory.

04/08/2012 16:01:35 ACN0520E Failed to connect to Local DSMAGENT Node 'FCMTEST' at address:port 'FCMTEST:10330'. Verify that the TSM Client Acceptor Daemon (CAD) is installed, configured, and running properly.

Cause

The Tivoli Storage Manager Client Acceptor Daemon (CAD) service is stopped and restarted unexpectedly in the middle of the backup.

Diagnosing The Problem

If a Tivoli Data Protection for Exchange trace with traceflag=service is captured, the following error message will appear in the trace:


04/08/2012 16:01:24.017 [013916] [14200] : vssproxy.cpp (2070): ConnectToDSMAgentNode(): Input parameters:
targetNodeNameP =
DSMAgentNodeNameP = FCMTEST
DSMAgentNodeHL = FCMTEST
DSMAgentNodeLL = 10330
...
04/08/2012 16:01:29.040 [013916] [14200] : dsmapi.cpp (3739): Exit DDsmApi::ddsmProxyInit(), rc = -50
04/08/2012 16:01:29.040 [013916] [14200] : vssproxy.cpp (2204): ConnectToDSMAgentNode():DSMPROXYINIT() failed. dsmrc=-50, msgBuffer=ACN0520E Failed to connect to Local DSMAGENT Node 'FCMTEST' at address:port 'FCMTEST:10330'. Verify that the TSM Client Acceptor Daemon (CAD) is installed, configured, and running properly.
04/08/2012 16:01:29.040 [013916] [14200] : vssproxy.cpp (2217): Exit ConnectToDSMAgentNode(), rc = 418

The RC=-50 indicates there is a TCP/IP communications failure.

The dsmwebcl.log shows that the Tivoli Storage Manager Client Acceptor restarts during the timeframe when the backup failure is seen:

04/08/2012 16:01:42 (dsmcad) IBM Tivoli Storage Manager
04/08/2012 16:01:42 (dsmcad) Client Acceptor - Built Apr 6 2011 09:03:43
04/08/2012 16:01:42 (dsmcad) Version 6, Release 2, Level 2.2
04/08/2012 16:01:42 (dsmcad) ANS3000I TCP/IP communications available on port 19618.
04/08/2012 16:01:42 (dsmcad) Dsmcad is working in Webclient mode.
04/08/2012 16:01:42 (dsmcad) ANS3000I HTTP communications available on port 1581.
04/08/2012 16:02:27 (dsmagent) IBM Tivoli Storage Manager
04/08/2012 16:02:27 (dsmagent) Remote Client Agent - Built Dec 3 2010 00:26:04
04/08/2012 16:02:27 (dsmagent) Version 6, Release 2, Level 2.0

Resolving The Problem

The Tivoli Storage Manager Client Acceptor Daemon (CAD) service is designed to be started once and left running indefinitely. The Tivoli Storage Manager Remote Client Agent service is dependent on the CAD service. So if the Tivoli Storage Manager Client Acceptor Daemon service is stopped, the Remote Client Agent service will also be stopped.

When a VSS backup is being performed, it is critical that there is no manual intervention to stop or restart the Client Acceptor Daemon or Remote Client Agent service. If either of these services are manually stopped or restarted during the backup processing, this can cause the backup to fail.

[{"Product":{"code":"SS36V9","label":"Tivoli Storage FlashCopy Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"FlashCopy Manager for Microsoft Exchange","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.2;3.1;3.2;4.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM FCM

Document Information

Modified date:
17 June 2018

UID

swg21576700