IBM Support What's New?

Agents for PeopleSoft Enterprise detects old events

Technote (troubleshooting)


Problem(Abstract)

The ITCAM for Applications Agents for PeopleSoft Enterprise read previously processed events from logs when they are restarted.

Symptom

Whenever a PeopleSoft Enterprise agent (P8, P9) is restarted, previous log entries are read from the beginning of the log and give the impression that a new event has been received.

The following situations are known to be affected by this issue
KP8_Agent_Log_Crit
KP9_Agent_Log_Crit
KP9_Run_Stat_No_Success
KP9_Run_Stat_Error


Cause

The cause has been traced to a value in the agent's .ref file.

The problem is in the line
"//SOURCE FILE '${CTIRA_LOG_PATH}/kp8_${KP8_INSTANCE_NAME}_trace.log'
TAILRESTARTFROMTOP ManagedSystemName=KP8_data_provider_log.txt"


Resolving the problem

The following work around will correct this issue.


1) Stop the agent exhibiting the issue.

2) Open the kp8.ref and / or kp9.ref files for editing.

Files are located in:
[candlehome]/lx8266/p8/bin/
[candlehome]/lx8266/p9/bin/

3) Edit the files to read TAIL instead of TAILRESTARTFROMTOP.

Change the line:
"//SOURCE FILE '${CTIRA_LOG_PATH}/kp8_${KP8_INSTANCE_NAME}_trace.log'
TAILRESTARTFROMTOP ManagedSystemName=KP8_data_provider_log.txt"

to read:
"//SOURCE FILE '${CTIRA_LOG_PATH}/kp8_${KP8_INSTANCE_NAME}_trace.log'
TAIL ManagedSystemName=KP8_data_provider_log.txt"

4) Start the agents

This defect has been fixed in APAR IV12618. Installing 6.2.1.3 Interim Fix 01 (6.2.1.3-TIV-ITM_PSFT-EAD-IF0001 / 6.2.1.3-TIV-ITM_PSFT-EPS-IF0001) or higher will resolve the problem.

Related information

6.2.1.3-TIV-ITM_PSFT-EAD-IF0001
6.2.1.3-TIV-ITM_PSFT-EPS-IF0001

Document information

More support for: Tivoli Composite Application Manager for Applications
Agent for PeopleSoft Enterprise

Software version: 6.2.1

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1576376

Modified date: 2016-04-27