Data written to an external USB disk has disappeared.

Technote (FAQ)


Question

A USB disk was connected to the FastBack server. The disk was formatted and files were copied to it. However, after it was disconnected from the FastBack server all the data disappered. The disk was found to be unformatted and did not contain the copied files. What did this happen?

Cause

After the FastBack server is installed it enables the disk write protection for all disks available on the FastBack server machine during the installation. If a new disk (an internal or external disk, including the USB disks on-key and storage based LUN's seen as drives in Windows Disk Management) is added to the FastBack server, the disk must be opened for read and write privileges before it is used. Otherwise the data will be written into the NTFS buffer only and won't be written to the physical disk.

Answer

Use the diskopen.exe utility supplied with the FastBack server application after the new disk is added to the system and before using that disk.

  1. Connect the disk to the FastBack server.
  2. Go to Windows Disk Management and find the newly added disk ID.
  3. Run the diskopen.exe utility in the following format:

    diskopen <disk ID> force forever

These steps should be performed for all newly added disks to disable the write protection option, regardless of whether they are internal or external (LUN's, external USB hard drives, USB Flash disks on-key etc.). This will allow any data to be written to the physical disk instead of just going into the buffer where it could subsequently be lost.

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Document information


More support for:

Tivoli Storage Manager FastBack
Server

Software version:

All Supported Versions

Operating system(s):

Windows

Software edition:

All Editions

Reference #:

1576256

Modified date:

2013-01-15

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