A product issue with IBM Content Integrator and IBM FileNet CFS for Content Integrator has been identified and immediate action is required to prevent potential document inconsistencies.

News


Abstract

An issue has been found with IBM Content Integrator and IBM® FileNet® CFS for Content Integrator that could lead to document inconsistencies under certain conditions when declaring an earlier version of a federated document as a record.

Installing ICI 8.6.0.0 IF002 and CE 5.1.0.0 IF002 are required to resolve this issue.

Content

This issue affects the following IBM FileNet P8 Content Manager (CM) and IBM FileNet P8 Business Process Manager (BPM) product components:
P8CE 5.1.0.0 at the GA base level
CFS-ICI 5.1.0.0 at the GA base level
ICI 8.6.0.0 at the GA base level

The issue only occurs when using IBM FileNet CFS for Content Integrator (CFS-ICI) to federate documents from a P8 source repository (at any version level) into a P8 5.1 target repository and when using IBM Enterprise Records (IER) in the target repository to declare a non-current document version as a record. In this situation, an incorrect version of the source document is declared.

The fix to the problem is in IBM Content Integrator (ICI) and requires a change to both the ICI server and the ICI client (that runs within CE and CFS).

To resolve this issue for future federated documents, install the following P8CE and ICI Interim Fixes and use the following manual procedure to update CFS-ICI:

A. P8CE 5.1.0.0 IF002 – refer to the Readme file in the Interim Fix for installation instructions

B. ICI 8.6.0.0 IF002 – refer to the Readme file in the Interim Fix for installation instructions.(Note that the critical fix is in IBM Content Integrator Interim fix ICI 8.6.0.0 IF002.)

C. Use the following manual procedure to update CFS-ICI with ICI 8.6.0.0 IF002.
(This updates CFS-ICI with the version of vbr.jar packaged with ICI 8.6.0.0 IF002)

Step I - Complete the following procedure on the server where IBM FileNet CFS for Content Integrator and IBM Content Integrator are installed.

  1. Log onto the server running CFS-ICI 5.1 and ICI 8.6 using the same login credentials used when they were installed.
  2. Stop the Content Federation Services Exporter. See "Managing Content Federation Services Exporter".
  3. Stop the VeniceBridgeServices script on the ICI Server.
  4. Stop the RMIBridges.
  5. Install ICI 8.6.0.0 IF002.
  6. Copy vbr.jar from <ici_install_path>/lib to <cfs_install_path>/FedExporter/lib
  7. Copy vbr.jar from <ici_install_path>/lib to <cfs_install_path>/FedAdmin/WEB-INF/lib
  8. Run the script to update the Federation Administration application.

    Windows

    <cfs_install_path>\create_fed_admin.bat

    Unix

    <cfs_install_path>/create_fed_admin.sh
  9. Log into the application server where the Content Federation Services Federation Administration application is deployed, and redeploy the new cfs_install_path/fed_admim_appserver.war. For more information, refer to "Deploying Content Federation Services Federation Administration application".
  10. Start the RMIBridges
  11. Start the VeniceBridgeServices script on the IBM Content Integrator Server.
  12. Start the Content Federation Services Exporter. See "Managing Content Federation Services Exporter".


Step 2 - Complete the following procedure on the machine that has an RMIBridges running.
  1. Log onto the server running the ICI connectors using the same login credentials used when they were installed.
  2. Stop the RMIBridges.
  3. Install ICI 8.6.0.0 IF002.
  4. Start the RMIBridges.

If you have been using CE 5.1.0 / CFS-ICI 5.1.0 to federate from a P8 source repository and declaring the federated documents as records in the target repository, contact the IBM Response Center at 1-800-IBM-SERV for steps to determine if your installation has been affected by this issue.

The Interim Fixes will be available on Fix Central and should be installed as soon as possible.

Fix Central can be found at: http://www-933.ibm.com/support/fixcentral/

For additional support questions, please contact the IBM Response Center at 1-800-IBM-SERV.

Cross reference information
Segment Product Component Platform Version Edition
Enterprise Content Management FileNet Content Manager Content Engine AIX, HP-UX, Linux, Solaris, Windows 5.1.0
Enterprise Content Management Content Integrator AIX, HP-UX, Linux, Solaris, Windows 8.6
Enterprise Content Management Enterprise Records AIX, HP-UX, Linux, Solaris, Windows 5.1.0

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

FileNet Content Federation Services
CFS for Content Integrator (CI)

Software version:

5.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1575753

Modified date:

2014-07-11

Translate my page

Machine Translation

Content navigation