IBM Support

User unable to send scheduled reports by email: CNC-SDS-0410 CNC-SDS-0379

Troubleshooting


Problem

When a report is scheduled to run and deliver the results as an attachment, errors are returned. Runs successfully when emailing interactively.

Symptom

Error messages appear in Cognos Connection:

CNC-SDS-0408 There are email messages waiting to be sent.


CNC-SDS-0410 The email message was not sent. Approximate message size: [29KB] The Mail server returned this error: [Invalid Addresses]
CNC-SDS-0379 Unable to send a message to an email address. Please check the value: abc@domain.com
A failure notification was sent.

Cause

The email address used as the default mail address in Cognos Configuration is invalid; hence the mail server is rejecting the request as the sender is invalid.

Diagnosing The Problem

When email is sent interactively, it is sent on behalf of the person executing the report. Whereas when run as a schedule, it uses the default sender defined in Cognos Configuration.

Resolving The Problem

Putting a valid email address as the default sender enables the user to email scheduled reports successfully.
Navigate to Cognos Configuration -> Notification Tab: Amend the default sender field to include a valid email address.
Default is notifications@cognos.com

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21575720