Troubleshooting
Problem
Backups for Exchange 2010 complete but the logs on the Exchange server do not truncate
Symptom
Exchange transaction logs continue to grow even after backups are completed
Cause
Fire wall time outs set too low
Environment
Exchange 2010 in a DAG environment using Data Protection for Microsoft Exchange server or Tivoli Storage Manager Flash copy Manger for Microsoft Exchange
Diagnosing The Problem
The Tivoli Storage Manager logs from the Tivoli Data Protection for Microsoft Exchange will show a successful completed backup, of the databases, However the logs for some or all of the databases continue to grow, there will be no errors in Exchange, but the application event log may show Remote Procedure Call (RPC) time out errors from windows after the time of the backup.
Resolving The Problem
The Data Protection for Exchange, used with FlashCopy Manager or alone does not truncate the Exchange logs, the Exchange server does the truncation after a completed backup. In a DAG environment where the passive copy of the database is backed up, the process for the truncation is driven by the backup server to the Exchange server where the ACTIVE copy of the database is hosted. This is done via RPC and there have been cases where a fire wall between the 2 Exchange hosts has its timeouts set so low that none of the connections between the Exchange servers last long enough to complete a truncation of the logs, alternately the truncate for small database may work but larger or busier database logs are not truncated.
To resolve the issue increase the firewall timeouts to allow the RPC service to remain connected so that all of the logs can be truncated.
Product Synonym
TSM FCM
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Document Information
Modified date:
17 June 2018
UID
swg21575087