Troubleshooting
Problem
On 64-bit Windows machines, when you try to upgrade IBM Rational ClearCase from one version to another in either the 7.1.1.x or 7.1.2.x streams, the upgrade succeeds, but later, you notice the product does not work as expected.
Symptom
You might notice several performance issues and see errors similar to the following:
C:\Users\user1>cleartool desc vob:\Sample-Doc cleartool: Warning: Cannot update license cache "C:\Program Files x86)
\IBM\RationalSDLC\ClearCase\var\cache\ClearCase_check\user1". Please check ownership or permission. versioned object base "\Sample-Doc"
Cause
The issue occurs because the <InstallDir>\ClearCase\var\cache folder is missing the "Everyone" group from permissions after product is upgraded.
Environment
This issue exists in ClearCase 7.1.1.7 and some 7.1.2.x releases, but it might also occur on any other versions based on 7.1.1 and 7.1.2.
Also, this issue occurs only on 64-bit machines. ClearCase installations running on 32-bit machines are working as expected.
Resolving The Problem
This issue is resolved in the following releases:
Rational ClearCase Fix Pack 07 (7.1.2.7) for 7.1.2
Rational ClearCase Fix Pack 7 (8.0.0.7) for 8.0
WORKAROUND:
Add the Everyone group back to the <InstallDir>\ClearCase\var\cache folder after the product is upgraded and restart ClearCase services before using the product.
Review the Set, View, Change, or Remove Permissions on Files and Folders article on microsoft.com for more details.
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Document Information
Modified date:
16 June 2018
UID
swg21574815