How to upgrade ClearCase, ClearQuest or RequisitePro web components to use WebSphere Application Server V8.x and IBM HTTP Server V8.x

Technote (FAQ)


Question

How do you upgrade IBM Rational ClearCase, IBM Rational ClearQuest and IBM Rational RequisitePro web components deployed in IBM WebSphere Application Server?

Answer

Legend

CC ClearCase
CQ ClearQuest
ReqPro RequisitePro
WAS WebSphere Application Server
IHS IBM HTTP Server
FTS Full Text Search
Summary

This technote describes the supported install, upgrade and rollback scenarios for ClearCase and ClearQuest versions 8.x and ReqPro version 7.1 and also provides tips on how to avoid problems. This technote includes a matrix that describes the supported configurations for each scenario.

Avoiding Problems

  1. Backup ClearCase metadata prior to performing an upgrade or rollback in the rare case that the operation fails before or during the backup of ClearCase metadata. See the following for instructions:
  2. Preserve ClearQuest Web configuration files before an upgrade or rollback operation to
  3. You cannot modify profile security settings during an upgrade. Use the WAS console to manage WAS administrative security.

  4. Roll back is not supported for the following upgrade paths. If a rollback is required, the product must be uninstalled and re-installed
    • From v8.0.0.x (x>=1) or v8.0.1 to v8.0 after you have deployed to WAS 8
    • From any v8.x to any v7.x.

  5. ReqPro cannot be rolled back from 7.1.3.x (x>=1) to 7.1.3 after you have deployed to WAS 8. If a rollback is required, the product must be uninstalled and reinstalled.

  6. If two or more of the CC, CQ, or ReqPro products share a single WAS profile, you cannot rollback from version 8.0.0.x (x>=1) or 8.0.1 to 8.0 for CC and CQ, or 7.1.3.x (x>=1) to 7.1.3 for ReqPro.

  7. Restart Installation Manager between successive operations when a system reboot is not requested.

  8. ClearQuest Web, Report Launcher and Report Server are all installed in the same profile. When upgrading or moving to a new WAS profile, all of these components must be upgraded or moved together.

  9. If the ClearQuest Full-Text Search feature is enabled, see technote #1574737 before modifying, redeploying or upgrading ClearQuest. If you are upgrading from ClearQuest version 7.x to version 8.x, also see technote #1516572.

  10. Be careful when overriding default port number assignments during the upgrade process. During upgrade or install operations, default port numbers are assigned to ensure that each port is unique. For example, if profile AppSrv01 was created in WAS 7 using port 9080, when create the AppSrv01 profile while upgrading to WAS 8, the port offered as default during profile creation will be 9081. If you override the default port number, you risk introducing port number conflicts.

  11. For known issues installing and configuring WAS/IHS V8 for CC/CQ/ReqPro, see technote #1573966.


Install/Upgrade/Rollback Support Matrix for ClearCase and ClearQuest

Table 1: Install/Upgrade/Rollback Support Matrix for ClearCase and ClearQuest

From
To
Comments
Instructions
CC/CQ WAS CC/CQ WAS
Install
None
None
8.0
8.0.0.x
Not Supported N/A
None
None
8.0.0.x (x>=0)
7.0.0.x
Supported See product documentation.
None
None
8.0.0.x (x>=1)
8.0.0.x
Supported See product documentation.
None
None
8.0.1
8.0.0.x
Supported See product documentation.
None
None
8.0.1
8.5.0.x
Supported See technote #1634430.
Upgrade -
7.1.1.x/7.1.2.x
6.1.0.25
8.0
8.0.0.x
Not Supported N/A
7.1.1.x/7.1.2.x
6.1.0.25
8.0.0.x (x>=0)
7.0.0.x
Supported See Scenario #1 below.
7.1.1.x/7.1.2.x
6.1.0.25
8.0.0.x (x>=1)
7.0.0.x or 8.0.0.x
Supported * See Scenario #2 below.
* ClearQuest upgrade not supported on Windows OS. See technote #1588364.
7.1.1.x/7.1.2.x
6.1.0.25
8.0.1
8.0.0.x or 8.5.0.x
Supported
8.0
7.0.0.x
8.0
8.0.0.x
Not Supported N/A
8.0
7.0.0.x
8.0.0.x (x>=1)
7.0.0.x
Supported See Scenario #3.
8.0
7.0.0.x
8.0.0.x (x>=1)
8.0
7.0.0.x
8.0.1
8.0.0.x or
8.5.0.x
Supported See Scenario #4.
Rollback –
8.x
7.x
Not supported
8.0.0.x (x>=1)
8.0.0.x
Any
Any
Not supported.
8.0.0.x (x>=1)
7.0.0.x
8.0.0.0
7.0.0.x
Supported See [Scenario #5] below.
Redeploy
  • Redeployment is applicable if moving from one WAS version to another.
  • CC/CQ WAS applications can be redeployed into a different version of WAS by modify/removing from the existing version of WAS and modify/adding into the desired version of WAS as described in Scenario #4.
  • See #5, #6, #8 and #9 in Avoiding Problems.
8.0
7.0.0.x
8.0.0.x
Not supported
8.0.0.x (x>=1)
7.0.0.x
8.0.0.x
Supported See Scenario #6.
8.0.0.x (x>=1)
8.0.0.x
7.0.0.x
Supported See Scenario #6.
Install/Upgrade/Rollback Support Matrix for RequisitePro

Table 2: Install/Upgrade/Rollback Support Matrix for RequisitePro

From
To
Comments
Instructions
ReqPro WAS ReqPro WAS
Install
None
None
7.1.3
8.0.0.x
Not Supported N/A
None
None
7.1.3.x (x>=0)
7.0.0.x
Supported See product documentation.
None
None
7.1.3.x (x>=1)
8.0.0.x
Supported See technote #1573917.
None
None
7.1.3.4
8.0.0.x or 8.5.0.x
Supported See technote #1573917.
Upgrade
7.1.1.x/7.1.2.x
6.1.0.25
7.1.3
8.0.0.x
Not Supported N/A
7.1.1.x/7.1.2.x
6.1.0.25
7.1.3.x (x>=0)
7.0.0.x
Supported See Scenario #1.
7.1.1.x/7.1.2.x
6.1.0.25
7.1.3.x (x>=1)
8.0.0.1
Supported See Scenario #2.
7.1.3
7.0.0.x
7.1.3.x (x>=1)
7.0.0.x
Supported See Scenario #3.
7.1.3
7.0.0.x
7.1.3
8.0.0.x
Not Supported N/A
7.1.3
7.0.0.x
7.1.3.x (x>=1)
8.0.0.x
Supported
7.1.3
7.0.0.x
7.1.3.4 (x>=1)
8.0.0.x or 8.5.0.x
Supported See Scenario #4.
Rollback –
7.1.3.x
7.1.1.x/7.1.2.x
Not supported
7.1.3.x (x>=1)
8.0.0.x
Any
Any
Not supported.
7.1.3.x (x>=1)
8.5.0.x
Any
Any
Not supported
7.1.3.x (x>=1)
7.0.0.x
7.1.3
7.0.0.x
Supported See Scenario #5.
Redeploy
  • See #8 and #9 in Avoiding Problems
  • Redeployment is applicable if moving from one WAS version to another.
  • The ReqPro WAS application can be redeployed into a different version of WAS by modify/removing from the existing version of WAS and modify/adding into the desired version of WAS as described in Scenario #4.
7.1.3
7.0.0.x
8.0.0.x
Not supported
7.1.3.x (x>=1)
7.0.0.x
8.0.0.x
Supported See Scenario #6.
7.1.3.x (x>=1)
8.0.0.x
7.0.0.x
Supported See Scenario #6.
7.1.3.4
8.0.0.x
8.5.0.x
Supported See Scenario #6.


Hide details for Scenario #1: UpgradeScenario #1: Upgrade

Table 3: Scenario 1 supported upgrade paths

Product
From
To
ClearCase
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v8.0 with WAS 7.0.0.x
ClearQuest
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v8.0 with WAS 7.0.0.x
RequisitePro
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v7.1.3 with WAS 7.0.0.x


Prerequisites:
  • Install WAS/IHS V7 (FP 15 or higher recommended). Select an install location outside the location of the current CC/CQ/ReqPro installation.
  • If you plan to deploy the product's web component into an existing WAS profile, verify the profile name and make sure it is started. Use the WebSphere Profile Management Tool or manageprofiles script to view and create profiles.
  • IHS V7 process/service must be running.


Procedure
  1. Start Installation Manager.
  2. To add the repository location of the products you have installed (CC V8.0, CQ V8.0 and/or ReqPro V7.1.3) to the Installation Manager's repository list, click File > Preferences. Then, click Add.
  3. From the Installation Manager start page, click Update in the Installation Manager.
  4. During the installation process, type or select the requested information when prompted.
  5. In the WAS security panel (example below), type the credentials for WAS administrative security for the applicable profile if security is enabled.

    Note:
    You cannot modify profile security settings during an upgrade. Use the WAS console to manage WAS administrative security.



Hide details for Scenario #2: UpgradeScenario #2: Upgrade

Table 4: Scenario 2 supported upgrade paths

Product
From
To
ClearCase
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v8.0.0.x (x>=1) with WAS 7.0.0.x or 8.0.0.x
ClearQuest
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v8.0.0.x (x>=1) with WAS 7.0.0.x or 8.0.0.x
RequisitePro
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v7.1.3.x (x>=1) with WAS 7.0.0.x or 8.0.0.x
RequisitePro
v7.1.1.x, v7.1.2.x with WAS 6.1.0.25 bundled
v7.1.3.4 with WAS 8.0.0.x or 8.5.0.x


Prerequisites:
  • Install WAS/IHS V7 (FixPack 15 or higher recommended), V8 (8.0 or higher), or V8.5.0.x. Select an install location outside the location of the current ClearCase installation.
  • If you plan to deploy the product's web component into an existing WAS profile, verify that that this profile is created and started. Use the WebSphere Profile Management Tool or manageprofiles script to create a new profile.
  • IHS V7 or V8 process/service must be running.


Procedure
  1. Start Installation Manager.
  2. To add repository for the products you have installed, add the location of both the base product (CC V8.0 or V8.0.1, CQ V8.0 or V8.0.1, and/or ReqPro V7.1.3 or V7.1.3.4) and the fixpack (CC V8.0.0.1, CQ V8.0.0.1, and/or ReqPro V7.1.3.1 or higher) repositories to the Installation Manager's repository list (File > Preferences).

    Alternatively, you can select Search service repositories during installation updates in File>Preferences...>Repositories.
  3. From the Installation Manager start page, click Update.
  4. During the installation process, type or select the requested information when prompted.
  5. In the WAS security panel (example below), type the credentials for WAS administrative security for the applicable profile if security is enabled.

    Note: You cannot modify profile security settings during an upgrade. Use the WAS console to manage WAS administrative security.


Hide details for Scenario #3: Upgrade (no change in WAS version)Scenario #3: Upgrade (no change in WAS version)

Table 5: Supported upgrade paths for Scenario 3

Product
From
To
ClearCase
v8.0 with WAS 7.0.0.x
v8.0.0.x (x>=1) with same WAS version
v8.0.0.x with WAS 8.0.0.x
v8.0.1 with same WAS version
ClearQuest
v8.0 with WAS 7.0.0.x
v8.0.0.x (x>=1) with same WAS version
v8.0.0.x with WAS 8.0.0.x
v8.0.1 with same WAS version
RequisitePro
v7.1.3 with WAS 7.0.0.x
v7.1.3.x (x>=1) with same WAS version
v7.1.3.x (x>=1) with WAS 8.0.0.x
v7.1.3.4 with same WAS version


Prerequisites:
  • WAS profiles and IHS processes must be running.


Procedure
  1. Start Installation Manager.
  2. To add the location of the Product (CC V8.0.0.1, CQ V8.0.0.1 or ReqPro V7.1.3.1 or higher) repositories to the Installation Manager's repository list, click File > Preferences. Then, click Add to specify the path.

    Alternatively, you can select Search service repositories during installation updates in File>Preferences...>Repositories.
  3. From the Installation Manager start page, click Update.
  4. During the installation process, type or select the requested information when prompted.
  5. In the WAS security panel (example below), type the credentials for WAS administrative security for the applicable profile if security is enabled.

    Note: You cannot modify profile security settings during an upgrade. Use the WAS console to manage WAS administrative security.






Hide details for Scenario #4: Upgrade (with change in WAS version)Scenario #4: Upgrade (with change in WAS version)

Table 6: Scenario 4 supported upgrade paths

Product
From
To
ClearCase
v8.0 with WAS 7.0.0.x
v8.0.0.x (x>=1) with WAS 8.0.0.x
v8.0 with WAS 7.0.0.x
v8.0.1 with WAS 8.0.0.x or WAS 8.5.0.x
v8.0.0.x (x>=1) with WAS 8.0.0.x
v8.0.1 with WAS 8.5.0.x
ClearQuest
v8.0 with WAS 7.0.0.x
v8.0.0.x (x>=1) with WAS 8.0.0.x
RequisitePro
v8.0 with WAS 7.0.0.x
v8.0.1 with WAS 8.0.0.x or 8.5.0.x
v7.1.3 with WAS 7.0.0.x
v7.1.3.x (x>=1) with WAS 8.0.0.x
v7.1.3 with WAS 8.0.0.x
v7.1.3.4 with WAS 8.5.0.x


Prerequisites:
  • Install WAS/IHS V8 (8.0 or higher). Select an install location outside the location of the current CC/CQ/ReqPro installation. See technote #1573917 for instructions on how to install and configure WAS/IHS V8 for CC/CQ/ReqPro.
  • If you plan to deploy the product's web component into an existing WAS profile, verify the profile name and make sure it is started. Use the WebSphere Profile Management Tool or manageprofiles script to view and create profiles.



Procedure for Option #1: [Do not use this if you have CQ web components installed, instead use Option #2]
  1. Remove the product's web component (CC V8.0 or ReqPro 7.1.3) from WAS 7.0.0.x.
    1. Start Installation Manager.
    2. Click Modify.
    3. Remove the selection from the relevant web component feature.
    4. Complete the modification.
  2. Upgrade the product to any of the following versions: CC V8.0.0.x (x>=1), V8.0.1 or ReqPro V7.1.3.x (x>=1), V7.1.3.4)
    1. Start Installation Manager.
    2. To add the location of the Product (CC V8.0.0.x (x>=1), V8.0.1 or ReqPro V7.1.3.x (x>=1), V7.1.3.4) repository to the Installation Manager's repository, click File > Preferences. Then, click Add to specify the path.
    3. From the Installation start page, click Update.
  3. Add the product's web component (to CC V8.0.0.x (x>=1), V8.0.1 or ReqPro V7.1.3.x (x>=1), V7.1.3.4)
    1. Start Installation Manager.
    2. Click Modify.
    3. Select the web components to be installed.

      During the installation process, type or select the requested information when prompted.
      Make sure to specify the correct values for WAS 8.0.0.x and IHS 8.0.0.x versions.

Procedure for Option #2:
The difference in this option is that it upgrades the products before removing them from the WAS profile.
  1. Upgrade the product(s) to any of the following versions: CC or CQ V8.0.0.x (x>=1), 8.0.1 or ReqPro V7.1.3.x (x>=1), V7.1.3.4.
    1. Start Installation Manager.
    2. To add the location of the product installation repository to the Installation Manage repository list, click File > Preferences. Then, click Add to specify the path.
    3. From the Installation Manager start page, click Update.
  2. Remove the product web component (CC or CQ V8.0.0.x (x>=1), V8.0.1 or ReqPro 7.1.3.x (x>=1) V7.1.3.4) from WAS 7.0.0.x.
    1. Start Installation Manager.
    2. Click Modify.
    3. Remove the selection from the relevant web component feature.
    4. Complete the modification.
  3. Add the product web component (CC or CQ V8.0.0.x (x>=1), V8.0.1 or ReqPro V7.1.3.x (x>=1), V7.1.3.4 to WAS 8.0.0.x
    1. Start Installation Manager.
    2. Click Modify.
    3. Select the web components to be installed.

      During the installation process, type or select the requested information when prompted.
      Make sure to specify the correct values for the Websphere Application Server and IBM HTTP Server where you are deploying the web component (V8.0.0.x or V8.5.0.x).

Hide details for Scenario #5: Rollback (no change in WAS version)Scenario #5: Rollback (no change in WAS version)

Table 7: Scenario 5 supported rollback paths

Product
From
To
ClearCase
v8.0.0.x (x>=1) with WAS 7.0.0.x
v8.0 with same WAS version
ClearQuest
v8.0.0.x (x>=1) with WAS 7.0.0.x
v8.0 with same WAS version
RequisitePro
v7.1.3.x (x>=1) with WAS 7.0.0.x
v7.1.3 with same WAS version


Prerequisites:
  • WAS and IHS processes/services must be running.
  • You must not have deployed to WAS V8 yet.

  • See #6 in Avoiding Problems

Procedure
  1. Start Installation Manager.
  2. To verify that the location of the product (CC V8.0, CQ V8.0 or ReqPro V7.1.3) repository has been configured in Installation Manager.
    1. Open Installation Manager.
    2. Click File > Preferences.
    3. Check the list of repositories to make sure the product repository is available and selected.
  3. To rollback the product, click Rollback in the Installation Manager.

    During the installation process, type or select the requested information when prompted.


Hide details for Scenario #6: Redeploy Rational web apps to a new WAS versionScenario #6: Redeploy Rational web apps to a new WAS version

Prerequisites:

  • Install the requisite WAS/IHS versions supported by the product you want to redeploy. Select an install location outside the location of the current ClearCase installation. For V8.0.0.x installation and configuration instructions, see technote #1573917. For version 8.5.0.x instructions, see technote #1634430.
  • Make sure the products are at a supported version (CC 8.0.0.1, CQ 8.0.0.1 and/or ReqPro 7.1.3.1) or higher
  • If you plan to deploy the product web component into an existing WAS profile, verify the profile name and make sure it is started. Use the WebSphere Profile Management Tool or manageprofiles script to view and create profiles.


Procedure
  1. Remove the product's web component from the existing WAS version.
    1. Start Installation Manager.
    2. Click Modify.
    3. Remove the selection from the relevant web component feature.
    4. Complete the modification.
  2. Add the product's web component into the desired WAS version.
    1. Start Installation Manager.
    2. Click Modify.
    3. Select the web component features to install.

      During the installation process, type or select the requested information when prompted.

      Note:
      Type information relevant to the desiredWAS and IHS versions

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearQuest Web Server (7.1) AIX, Linux, Solaris, Windows 8.0.0.1, 8.0.0.2, 8.0.0.3, 8.0.0.4, 8.0.0.5, 8.0.0.6, 8.0.0.7, 8.0.1
Software Development Rational RequisitePro RequisiteWeb Windows 7.1.3.1, 7.1.3.2, 7.1.3.3, 7.1.3.4

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational ClearCase
CCRC WAN Server

Software version:

8.0.0.1, 8.0.0.2, 8.0.0.3, 8.0.0.4, 8.0.0.5, 8.0.0.6, 8.0.0.7, 8.0.0.8, 8.0.0.9, 8.0.0.10, 8.0.0.11, 8.0.0.12, 8.0.1, 8.0.1.1, 8.0.1.2, 8.0.1.3, 8.0.1.4, 8.0.1.5

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1572830

Modified date:

2014-09-17

Translate my page

Machine Translation

Content navigation