Installing IBM Records Manager with DB2 9.1 Fix Pack 11

Technote (troubleshooting)


Problem(Abstract)

If you use DB2 9.1 Fix Pack 11, the IBM Records Manager 8.5 or IBM Records Manager 8.5 fix pack installation program cannot install the application because DB2 9.1 Fix Pack 11 is not recognized as a supported level.

Symptom

When you run the IBM Records Manager 8.5 or IBM Records Manager 8.5 fix pack installation program, you receive the following message:

The DB2 service level is not the same as the level that is defined by the system requirements.



Resolving the problem

Before you install IBM Records Manager, replace two class files in the IBM Records Manager 8.5 or IBM Records Manager 8.5 fix pack installation package.

To replace the class files:

  1. Extract the IBM Records Manager installation package to a temporary directory.
  2. Open the config/IRMDBUtil.jar file. For example, use a file compression utility that supports JAR files.
  3. Add the following two class files to the MDBUtil.jar\com\ibm\gre\dbdevman\DBAdminOperations directory, overwriting the existing files.

DB2SmallAdminUtils.class DB2SmallAdminUtils$DB2DirectoryScanner.class

After you replace the files, run the IBM Records Manager installation program.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Records Manager

Software version:

8.5, 8.5.0.1, 8.5.0.2, 8.5.0.3, 8.5.0.4, 8.5.0.5

Operating system(s):

AIX 5.3, AIX 6.1, Windows 2008 server, Windows Server 2003

Software edition:

DB2 9.1

Reference #:

1572743

Modified date:

2012-10-17

Translate my page

Machine Translation

Content navigation