Troubleshooting
Problem
Historical data is collected at the TEMS, but no data sent by the Warehouse Proxy Agent and transferred to the warehouse.
Symptom
TEMS log file shows errors like:
(4E9D786E.0000-19:khdxcnfg.cpp,2184,"locateConfigRecord") Configuration cache initialization error, status 66!
(4E9D786E.0001-19:khdxdacl.cpp,640,"routeExportRequest") sourceObject open() failed, status = 66, for object <Linux_NFS_Statistics> table LNXNFS appl KLZ
from different agents.
Cause
failing file or corruption in khdexp.cfg
Resolving The Problem
These errors indicate that there is a problem with the khdexp.cfg file for the particular agent mentioned in the error.
Here is some information on what the file does.
khdexp.cfg is a data file maintained at the collection location that stores data about the last record exported to the database per attribute group (table).
The data in this file serves as a marker which shows each export thread where to start in the short term historical binary file for the export of new data.
The KHD export code creates this file after the first successful data export.
At the expiration of each Warehouse Interval, the export thread parses khdexp.cfg for the attribute group for which it's exporting data and uses the corresponding timestamp found as its starting place.
Since the historical files are on the TEMS then there is one file; by default this is in /tems/itm6/tables/TEMS
To resolve this issue the TEMS will need to be stopped, and the file khdexp.cfg should be removed from the directory to a storage place.
The TEMS can then be restarted, a new khdexp.cfg will be generated and the export of the data should then start as expected.
Product Synonym
ITM;Monitoring
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Document Information
Modified date:
17 June 2018
UID
swg21570404