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ANS9020E RC=-53 VSS backup for the Data Protection client failure.

Troubleshooting


Problem

ACN0520E Failed to connect to Local DSMAGENT Node or ANS9020E Return code is -53; invalid TCP/IP address

Symptom

Different errors will be seen in different environments, for example:

ACN0520E Failed to connect to Local DSMAGENT Node 'EXCHSERVER' at address:port 'exchmachine.somedomain.com:59631'.

ANS9020E Could not establish a session with a TSM server or client agent. The TSM return code is -53.

Cause

The Tivoli Storage Manager Server is unable to contact the Tivoli Storage Manager Client Acceptor service on the client machine using TCP/IP.

Diagnosing The Problem

When attempting to perform a Data Protection client backup using VSS, this is failing with the error:

04/21/2011 17:32:03 ANS9020E Could not establish a session with a TSM server or client agent. The TSM return code is -53.
04/21/2011 17:32:03 ANS1033E An invalid TCP/IP address was specified.

04/21/2011 17:32:08 ANS1033E (RC-53) An invalid TCP/IP address was specified.
04/21/2011 17:32:41 ACN5060E A Tivoli Storage Manager API error has occurred.

ACN5229E Error obtaining VSS information from Local DSMAgent Node: 'BACLIENT1'.
ANS1033E (RC-53) An invalid TCP/IP address was specified.

The RC=-53 return code is defined as: RC_BAD_HOST_NAME - TCP/IP invalid host name specified

Verify the TCP/IP address(s) for the client machine by running: ipconfig /all
Check whether there are multiple IP addresses, for example if there are multiple NIC cards in the machine.

Also verify the DNS lookup from the Tivoli Storage Manager Server machine and that the hostname address for the client machine will correctly resolve to a TCP/IP address that is able to ping the client machine.

Resolving The Problem

Tivoli Storage Manager VSS operations use the Tivoli Storage Manager Client Acceptor and Remote Client Agent services. The Data Protection client will first connect to the Tivoli Storage Manager Server. The Tivoli Storage Manager Server will then provide the Data Protection client with the TCP/IP connection information for contacting and interacting with the Client Acceptor and Remote Client Agent services.

By default, the Tivoli Storage Manager Server gets the TCP/IP connection information for the node using DNS services when this node initially connects to the Tivoli Storage Manager server. In cases where there are multiple NIC cards or different TCP/IP addresses for the client machine, the Tivoli Storage Manager Server may be unable to successfully connect to the Tivoli Storage Manager client services.

If the default client TCP/IP address is not valid or there are DNS issues, the TCPCADADDRESS option can be set in the client options file (default is C:\Program Files\Tivoli\TSM\baclient\dsm.opt), For example:
TCPCADADDRESS localhost.dotted.decimal.address
The value for this TCPCADADDRESS needs to be set to the TCP/IP address that the Tivoli Storage Manager Server would use to successfully ping the client machine.

After this new parameter is placed in the dsm.opt, then restart the Tivoli Storage Manager Client Acceptor (dsmcad) service and retry the operation.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21570334