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IBM WebSphere Lombardi Edition (WLE) LDAP full name retrieval does not work after applying Fix Pack 2

Troubleshooting


Problem

After you upgrade to WebSphere Lombardi Edition Version 7.2.0 Fix Pack 2 or 7.1.0 Fix Pack 2, apply WebSphere Application Server fix packs, and modify the wimconfig.xml file, full user names do not seem to work. The instructions here are for a federated respository configuration.

Cause

WebSphere Lombardi Edition uses the fullName column in the LSW_USR_XREF table when displaying the full name of a user. This name is only updated when one of the following conditions are true:

  • The user is new to WebSphere Lombardi Edition and a new record is entered into the database.
  • Synchronization occurs on the user name.
  • Full synchronization occurs on all user groups.

Resolving The Problem

For this issue, there are multiple resolutions. Check all causes as one or more might apply to your system.

  • An incorrect level exists for WebSphere Application Server

    You need to apply the PM37925 and PM18594 fixes, which are mentioned in Fix Pack 2. These are interim fixes in Fix Central that you can apply to WebSphere Application Server Version 7.0.0 Fix Pack 7, which is the default level of WebSphere Application Server for WebSphere Lombardi Edition.

  • Lightweight Directory Access Protocol (LDAP) does not have a displayName entry

    The instructions state to add an entry with displayName to the wimconfig.xml file. The file willb e located in a directory similar to [install_directory]\AppServer\profiles\Lombardi\config\cells\[cell_name]\wim\config\wimconfig.xml This field is a default field in Microsoft Active Directory. If your LDAP entries do not have this field, use a field that contains the desired full name. Generally the CN field has a full name entry.

    Instead of:

    <config:userDisplayNameMapping propertyForInput="displayName" propertyForOutput="displayName"/>

    use:
    <config:userDisplayNameMapping propertyForInput="cn" propertyForOutput="cn"/>

  • Full synchronization does not work, however synchronizing individual names updates the specified users' the full name field

    A full synchronization queries all entries in LDAP. This process is limited by the maximum search value in the wimconfig.xml. In WebSphere Application Server, the default maximum search results is 4500 entries. This value is not the maximum number of LDAP users that WebSphere Application Server can handle; rather, it is the maximum number that is returned based on the configuration value in the wimconfig.xml file. Check the SystemOut.log file for the twprocsvr server and the CWWIM1018E error code.

    Example error:
    2011-10-13 09:47:04,898 [WebContainer : 0] ERROR
    com.lombardisoftware.userorg.WSAbstractUserRegistryModule  - Exception:
    com.ibm.websphere.security.CustomRegistryException
    com.ibm.websphere.wim.exception.MaxResultsExceededException: CWWIM1018E  '5671' search results exceeds the '4500' maximum search limit.

    Increase the maximum search results in the wimconfig.xml file as described in the MaxResultsExceededException occurs during LDAP repository search topic within the WebSphere Application Server Information Center. After the change, restart both the WebSphere Application Server and WebSphere Lombardi Edition servers, then complete a full synchronization.

[{"Product":{"code":"SSFPRP","label":"WebSphere Lombardi Edition"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"LDAP Integration","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.2.0.2;7.1.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

WLE ;WAS

Document Information

Modified date:
15 June 2018

UID

swg21570176