Troubleshooting
Problem
The Self Service Center does not fully load. The applets on the right never appear. Also there is a SECJ0053E security error in the systemerr.log.
Symptom
systemerr.log will have this error:
[10/26/11 10:59:30:048 PDT] 000000b2 SystemErr R Caused by:
com.ibm.websphere.csi.CSIAccessException: SECJ0053E: Authorization
failed for /UNAUTHENTICATED while invoking
(Bean)ejb/maximo/remote/accesstokenprovider getAccessToken:3
securityName: /UNAUTHENTICATED;accessID: UNAUTHENTICATED is not granted
any of the required roles: maximouser
at
com.ibm.ws.security.core.SecurityCollaborator.performAuthorization(Secur
ityCollaborator.java:486)
at
com.ibm.ws.security.core.EJSSecurityCollaborator.preInvoke(EJSSecurityCo
llaborator.java:218)
at
...
Cause
LDAP Security has been enabled in WAS but the web.xml for the Self Service Center had not been set to enable security for this application.
Resolving The Problem
On the Admin Workstation, edit the web.xml file found in this directory:
C:\IBM\SMP\maximo\applications\maximo\maxrestweb\webmodule\WEB-INF
(Assuming default installation directory on Windows. Adjust directory name according to your installation.)
In the web.xml file, make both of these changes:
1) Find the <security-constraint> stanza. In order to enable
it for security, remove the comment markers that you will find
before and after this stanza.
2) Find the "useAppServerSecurity" setting. Change it's value
to "1". Notice the value is set on the last line of the stanza.
After the change this should look like:
<env-entry-name>useAppServerSecurity</env-entry-name>
<env-entry-type>java.lang.String</env-entry-type>
<env-entry-value>1</env-entry-value> </env-entry>
Then rebuild and redeploy the Maximo EAR.
In general, you want the security settings in the web.xml of the
Self Service Center to be the same as that Maximo's web.xml. If
you wish to compare them, you can find Maximo's web.xml in this
directory:
\IBM\SMP\maximo\applications\maximo\maximouiweb\webmodule\WEB-INF
Our documentation should state that the above actions need to be
taken if WAS application security was turned on, in order to
keep the Self Service Center working.
Note:
Some SRM fixpack or Maximo fixpack installations may revert the web.xml configuration to the original state by updating this file. Therefore, if you have taken the above steps, make a back up copy of the web.xml file as you may need it after your next fixpack install. Also, after applying a fixpack, it is a recommended post-installation task to double check the web.xml file.
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Document Information
Modified date:
27 February 2019
UID
swg21569951