IBM Support What's New?

Rational Developer for System z Backward/Forward compatibility

Technote (FAQ)


Question

What levels of the IBM Rational Developer for System z host and client are compatible?

Answer

Client/Server Compatibility
In general, Rational Developer for System z follows a two level backward and forward compatibility tolerance for basic Client /Server functionality.

Rational Developer for System z v9.5.x host/client is compatible with versions v9.5.x, v9.1.x, and v9.0.x client/host.

Rational Developer for System z v9.1.x host/client is compatible with versions v9.5.x, v9.1, v9.0.x, and v8.5.x client/host.

Rational Developer for System z v9.0.x host/client is compatible with versions v9.5.x, v9.1.x, v9.0.x, v8.5.x and v8.0.x client/host.

Rational Developer for System z v8.5.x host/client is compatible with versions v9.1, v9.0, v8.5, v8.0.x, and v7.6.x client/host.

Rational Developer for System z v8.0.x host/client is compatible with versions v9.0, v8.5, v8.0.x, and v7.6.x client/host.

Rational Developer for System z v7.6.x host/client is compatible with versions v8.5, v8.0.x, and v7.6.x client/host.

Basic Client/Server functionality includes:

• Connecting to a z/OS System
• Allocating z/OS Data sets
• Creating a z/OS Project
• Working with z/OS COBOL & Pl/I remote assets – edit, syntax check, submit, execute, debug and view the output
• Basic CARMA functionality
• Compatibility between service levels within a release is also supported (for example, using the v8.0.2 client to access a v8.0.1 server).


As an example, if you upgrade your Developer for System z host to v9.5.x, client versions v9.0.x, v9.1.x and v9.5.x are compatible with the v9.5.x server.
Likewise, if you upgrade your Developer for System z client to v9.5.x, server versions v9.0.x, v9.1.x and v9.5.x are compatible with the v9.5.x client.

Note: Server enhancements that are client-dependent are not available to developers using earlier versions of the client.

Client enhancements that are server-dependent are not available to developers accessing earlier versions of the server.

For the Integrated Debugger,

• Developer for System z v9.0.1.1 or later clients can connect to either Developer for System z V9.0.1.x servers.
• Developer for System z v9.1x clients can connect to Developer for System z v9.5.x, v9.1.x, V9.0.1.x servers.
• Developer for System z v9.5x clients can connect to Developer for System z v9.5.x, v9.1.x, V9.0.1.x servers.

Workspace Data Compatibility

Rational Developer for System z supports upward compatibility of workspace data but does not support backward compatibility of the workspace as a whole or of individual artifacts.

Workspace data may be used with updated versions, mod levels and interim fixes of clients but is not backward compatible. For example, a workspace used with Rational Developer for System z v8.5 may be used with Rational Developer for System z v9.5 but after it is used with Rational Developer for System z v9.5 it can no longer be used with Rational Developer for System z v8.5. This policy also applies to individual artifacts of a work space, for example, property groups.

Document information

More support for: Rational Developer for System z
General Information

Software version: 7.6, 7.6.1, 7.6.2, 7.6.2.2, 7.6.2.3, 7.6.2.4, 7.6.2.5, 7.6.2.6, 8.0.1, 8.0.2, 8.0.3, 8.0.3.1, 8.0.3.2, 8.0.3.3, 8.0.3.4, 8.0.3.5, 8.0.3.6, 8.5, 8.5.0.1, 8.5.1, 8.5.1.1, 8.5.1.2, 8.5.1.3, 8.5.1.4, 8.5.1.5, 8.5.1.6, 9.0, 9.0.0.1, 9.0.1, 9.0.1.1, 9.0.1.2, 9.0.1.3, 9.0.1.4, 9.1, 9.1.1, 9.1.1.1, 9.1.1.2, 9.5, 9.5.1

Operating system(s): Linux, Windows, z/OS

Software edition: All Editions

Reference #: 1568844

Modified date: 2015-12-16