Troubleshooting
Problem
ALL jobs received error EM_NETCONN(207): Error in doing a network connect.CLI Error Message: {2}
Cause
There are too many defunct processes in Teradata Server
Resolving The Problem
This error indicates that the source Teradata database was not reachable during job execution. Thus, these should be checked
1) /etc/hosts to ensure the corresponding Teradata database hostname and ip address are correct
2) Use bteq installed in the same machine as DataStage engine to verify the connectivity to the source database.
3) Check the Teradata Server to see if there are many defunct TCP/IP connections.
Cleanup and re-start the server.
[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"8.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21568263