Question & Answer
Question
How do you make global search work on a multi-server cluster?
Cause
PMObjSearchCron can only be run on one of the servers
Answer
Global Search utilizes search across multiple MBO and attachment files
Global Search is done through:
Navigation: GoTo -> Service Desk -> Global Search
The search feature of Global Search uses the open source framework of Lucene from Apache. Before a search will work, the MBO data must be indexed. Lucene indexes data to be searched and stored in a specific path.
Since the PMObjSearchCron can only be run on one of the servers, you
can create a common shared drive, then
configure theLUCENEOBJINDEX on all these clusters to point to this
path so all clusters will be accessing the same updated index.
See the following link for configuring System Properties for Search Functions.
[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5;7.2.1;7.2;7.1.2;7.1.1;7.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21567890