Technote (troubleshooting)
This document applies only to the following language version(s):
English
Problem(Abstract)
Need to remove Fast Batch object and the associated write_request from IBM FileNet Image Services
Symptom
Document requests are stuck in Image Services and needs to know how to delete the bad batches.
Cause
Changing doc ID's while committing batches or incorrect Index data.
Diagnosing the problem
Elog shows that you cannot commit batches. Errors repeat on each startup of Image Services.
2012/11/02 03:33:39.152 151,0,39 <fnsw> dtp_tran ...
WQS: the value '0000012345' for field 'data_in' is longer than the defined length of 9 in workspace 'Workspace' and queue 'Queue'.
2012/11/02 03:33:39.200 151,0,39 <fnsw> dtp_tran ...
INXl_import: first error at record 22
2012/11/02 03:33:39.655 90,0,24 <fnsw> dtp_tran ...
dtp_tran: Error cataloging docs for batch with object id 4160000001
Resolving the problem
Delete the fast batches that are giving errors in the elog
1) MKF_tool
<MKF_tool>select write_request * where doc_id=41600000001
doc_id.........4160000001 family_id...............8
num_pages............2579
req_type................1
batch_name..........."Batch_name"
2) <MKF_tool>allowupdates
Password? xxxxxxxxxxxx
Updates now allowed
<MKF_tool>del write_request doc_id=4160000001
Total of 1 records deleted
<MKF_tool>q
3)Then delete it from cache
CSM_tool
<CSM_tool>deleteobject <cache id> <ssn> <object_id or document id>
<CSM_tool>quit
Example of delete command:
<CSM_tool>allowupdates
password xxxx
<CSM_tool>deleteobject 1 1100111111 4160000001
<CSM_tool>quit
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.