Hardware and Software Requirements: Version 6.3 TSM for Virtual Environments

Preventive Service Planning


Abstract

This document details the Hardware & Software requirements for Tivoli Storage Manager (TSM) for Virtual Environments 6.3.

Content

This document details the Hardware & Software requirements for Tivoli Storage Manager (TSM) for Virtual Environments 6.3.

The TSM for Virtual Environments requirements vary by high level functional component. TSM for Virtual Environments has the following high level functional components:

    • vCenter Plug-in
    • Data Mover
    • Recovery Agent
    • Recovery Agent Command Line Interface

This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.



Supported VMware vSphere versions

vCenter Plug-in supported operating systems
Data Mover supported operating systems
Recovery Agent & Recovery Agent Command Line Interface supported operating systems
Additional hardware and software requirements

Where to download Tivoli Storage Manager for Virtual Environments 6.3.0



Supported VMware vSphere versions

The following VMware vSphere versions are supported:
  • vSphere 4.0
  • vSphere 4.1
  • vSphere 5.0



vCenter Plug-in

This functional component integrates the product with the VMware vSphere client in order to back up, restore, and manage virtual machines in the vCenter and includes the Data Protection for VMware command-line interface. The supported operating systems by platform are detailed below.
    Linux x86_64 platform

    The following operating systems are supported for the vCenter Plug-in on the Linux x86_64 platform.
    • Red Hat Enterprise (RHEL) Linux 5 Update 2, and later mod levels and fix packs: Desktop and Advanced Platform Editions
    • Red Hat Enterprise (RHEL) Linux 6, and later mod levels and fix packs: Desktop and Advanced Platform Editions
    • SUSE Enterprise Linux 11, and later mod levels and fix packs: Desktop and Server Editions

    Windows x86 platform

    The following operating systems are supported for the vCenter Plug-in on the Windows x86 platform.
    • Windows Server 2003, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2003 R2, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2008, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows 7, and later Service Packs: Enterprise, Professional, and Ultimate Editions


    Windows x64 platform
    The following operating systems are supported for the vCenter Plug-in on the Windows x64 platform.
    • Windows Server 2003, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2003 R2, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2008, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows Server 2008 R2, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows 7, and later Service Packs: Enterprise, Professional, and Ultimate Editions

Data Mover

The Data Mover is installed on the vStorage Backup Server and enables off-host block level incremental backups. This function is enabled by the installation of the Tivoli Storage Manager (TSM) Backup-Archive Client 6.3.0, or later. The TSM Backup-Archive Client is a separate prerequisite and not included in the TSM for Virtual Environments installation package.

Though the TSM Backup-Archive Client supports a wide variety of operating systems, only a subset of those operating systems are supported with TSM for Virtual Environments.
  • The 6.3.0 level of the TSM Backup-Archive client, or later fix packs or interim fixes of this release, is required with TSM for Virtual Environments 6.3.

WARNING: The TSM API Client 6.3.0 is also a prerequisite of TSM for Virtual Environments 6.3.0 and is automatically installed as a part of the TSM for Virtual Environments 6.3.0 installation process. The TSM Backup-Archive Client and TSM API levels must remain in sync. Therefore, future updates to either the TSM Backup-Archive Client or the TSM API require that the other component be updated at the same time.

The following operating systems are supported for the Data Mover / TSM Backup-Archive Client with TSM for Virtual Environments.
    Linux x86_64 platform

    The following operating systems are supported for the Data Mover on the Linux x86_64 platform.
    • Red Hat Enterprise (RHEL) Linux 5 Update 2, and later mod levels and fix packs: Desktop and Advanced Platform Editions as also supported by the VMware Virtual Disk Development Kit (VDDK) 5.0
    • Red Hat Enterprise (RHEL) Linux 6, and later mod levels and fix packs: Desktop and Advanced Platform Editions as also supported by the VMware Virtual Disk Development Kit (VDDK) 5.0
    • SUSE Enterprise Linux 10 SP2, and later mod levels and fix packs: Desktop and Server Editions as also supported by the VMware Virtual Disk Development Kit (VDDK) 5.0
    • SUSE Enterprise Linux 11, and later mod levels and fix packs: Desktop and Server Editions as also supported by the VMware Virtual Disk Development Kit (VDDK) 5.0


    Windows x86 platform
    The following operating systems are supported for the Data Mover on the Windows x86 platform.
    • Windows Server 2003, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2003 R2, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2008, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, Starter, and Ultimate Editions


    Windows x64 platform

    The following operating systems are supported for the Data Mover on the Windows x64 platform.
    • Windows Server 2003, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2003 R2, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2008, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows Server 2008 R2, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, and Ultimate Editions


Recovery Agent & Recovery Agent Command Line Interface

This function provides virtual mount and instant restore capabilities. The supported operating systems by platform are detailed below.
    Linux x86 Platform

    The following operating systems are supported for the Recovery Agent on the Linux x86 platform.

      Note: The Recovery Agent Command Line Interface (CLI) is not supported on the Linux x86 platform. Only the Recovery Agent its self is supported.
    • Red Hat Enterprise (RHEL) Linux 5 Update 2, and later mod levels and fix packs: Desktop and Advanced Platform Editions
    • Red Hat Enterprise (RHEL) 6, and later mod levels and fix packs: Desktop and Advanced Platform Editions
    • SUSE Enterprise Linux 10 SP2, and later mod levels and fix packs: Desktop and Server Editions
    • SUSE Enterprise Linux 11, and later mod levels and fix packs: Desktop and Server Editions


    Linux x86_64 Platform
    The following operating systems are supported for the Recovery Agent on the Linux x86_64 platform.

      Note: The Recovery Agent Command Line Interface (CLI) is not supported on the Linux x86_64 platform. Only the Recovery Agent its self is supported.
    • Red Hat Enterprise (RHEL) Linux 5 Update 2, and later mod levels and fix packs: Desktop and Advanced Platform Editions
    • Red Hat Enterprise (RHEL) Linux 6, and later mod levels and fix packs: Desktop and Advanced Platform Editions
    • SUSE Enterprise Linux 10 SP2, and later mod levels and fix packs: Desktop and Server Editions
    • SUSE Enterprise Linux 11, and later mod levels and fix packs: Desktop and Server Editions


    Windows x86 Platform

    The following operating systems are supported for the Recovery Agent on the Windows x86 platform.
    • Windows Server 2003 SP1, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2003 R2, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2008 SP1, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, Starter, and Ultimate Editions
    • Windows Vista SP1, and later Service Packs: Business, Enterprise, Home Basic, Home Premium, Starter, and Ultimate Editions
    • Window XP Professional SP2, and later Service Packs


    Windows x64 Platform

    The following operating systems are supported for the Recovery Agent on the Windows x64 platform.
    • Windows Server 2003 SP1, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2003 R2, and later Service Packs: Standard, Enterprise, Storage Server, and Storage Server R2 Editions
    • Windows Server 2008 SP1, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows Server 2008 R2, and later Service Packs: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
    • Windows 7, and later Service Packs: Enterprise, Home Premium, Professional, and Ultimate Editions
    • Windows Vista SP1, and later Service Packs: Business, Enterprise, Home Premium, Starter, and Ultimate Editions
    • Window XP Professional SP2, and later Service Packs



Additional hardware and software requirements

The following additional software is required to use TSM for Virtual Environments:
  • Tivoli Storage Manager (TSM) Server 6.1.3, or later

  • Tivoli Storage Manager (TSM) API 6.3.0, or later fix packs or interim fixes of this release
    WARNING: The TSM API Client 6.3.0 is also a prerequisite of TSM for Virtual Environments 6.3.0 and is automatically installed as a part of the TSM for Virtual Environments 6.3.0 installation process. The TSM Backup-Archive Client 6.3.0 is a prerequisite to using the Data Mover function for off-host block level incremental backups. The TSM Backup-Archive Client and TSM API levels must remain in sync. Therefore, future updates to either the TSM Backup-Archive Client or the TSM API require that the other component be updates at the same time.

All other hardware and software requirements are detailed in the "Planning" topic of the TSM for Virtual Environments 6.3 Installation and Planning Guide which is available at the following URL: http://publib.boulder.ibm.com/infocenter/tsminfo/v6r3/topic/com.ibm.itsm.ve.doc/c_ve_planning.html


Where to download Tivoli Storage Manager for Virtual Environments 6.3.0

The Tivoli Storage Manager for Virtual Environments download document provides information about how and where to obtain the Tivoli Storage Manager for Virtual Environments 6.3.0 package. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24030317

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Storage Manager for Virtual Environments
Data Protection for VMware

Software version:

6.3

Operating system(s):

Linux, Windows

Reference #:

1567566

Modified date:

2012-11-16

Translate my page

Machine Translation

Content navigation