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The current user count does not reflect the actual number of users logged into the system

Troubleshooting


Problem

This technote explains why the number of users listed in the key performance indicators for current login and user sessions may not match the actual number of logged in users at any given time when using Maximo Asset Management..

Cause

Because the current user count is only updated every 15 minutes (at a minimum), the current user count sometimes does not reflect the actual users logged into the system


Details
The key performance indicators (KPIs) for current login and user sessions uses the CURRENTCOUNT column in the LOGINTRACKING table. The value of the CURRENTCOUNT column is updated based on the interval specified in the mxe.ClientCountMinutes property.

The minimum for the update interval is 15 minutes. Even though a user can set a different update interval in the user interface, the minimum value for the mxe.ClientCountMinutes property is always 15 minutes.

Consider the following example:

TimeActionNumber of users
in the KPI counts
Actual number of users
who are logged in
12.01 Mary logs in
1
1
12:08 John logs in
1
2
12:12 Lucy logs in
1
3
12:15 Update interval is reached, the counter sets to 3
3
3
12:16 Steve logs in
3
4
12:18 Mary logs out
3
3
12:19 Steve logs out
3
2

Resolving The Problem

No action required - this technote is for information purposes only.

When the number of users in the KPI counts is reviewed closely, particularly in a small environment where users frequently log in and log out, the numbers do not match up. However, in a production system with many users working over an entire day, these numbers will normalize and reflect actual usage.


For more information on how to create KPIs, refer to the Creating key performance indicators topic in the Knowledge Center.

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Document Information

Modified date:
17 June 2018

UID

swg21515715