Installation of Rational Synergy iFix fails - installed prerequisite is not detected

Technote (troubleshooting)


Applying an iFix or Fixpack to a Rational Synergy 7.x database fails, reporting that it needs a patch that is already installed.


Here is an example of the failure:

ccm_patch -dbonly $CCM_HOME/patches/ <dbpath>

This patch ( needs patch

First apply patch to <dbpath>,

then apply to <dbpath>


Incorrect version of the ccm_patch utility being used.


Rational Synergy 7.x on UNIX/Linux server

Resolving the problem

Use the correct version of the ccm_patch installer to resolve this problem.

To check the version of your current ccm_patch, run the command

ccm_patch -version

Currently, fixpacks and iFixes to Rational Synergy 7.1 or 7.2 require version 47 of the ccm_patch utility. Download the required version from the same web page hosting the fixpack or iFix.

The current version of the ccm_patch installer script can be accessed from the following URL:

Document information

More support for:

Rational Synergy
General Information

Software version:


Operating system(s):

AIX, HP-UX, Linux, Solaris

Reference #:


Modified date:


Translate my page

Content navigation