Troubleshooting
Problem
After installing and Information Server patch or fix pack, the DataStage grid tool kit is no longer enabled. Jobs will still run but are no longer grid enabled.
Cause
Some information Server patches or fix packs will overwrite the $APT_ORCHHOME/bin/osh or $APT_ORCHHOME/bin/orchadmin executables
Resolving The Problem
During the installation of the Grid Toolkit (GTK), the osh and orchadmin executables are renamed osh.exe and orchadmin.exe then replaced with scripts that call their executable counterparts as required by the GRID engine. When you install an Information Server patch these scripts may be overwritten.
To resolve this issue you need to verify that the Grid Toolkit script files have been overwritten. If they have then apply these steps for each file that was overwritten. Do not apply these steps if the file was NOT overwritten by the patch.
$ cd $APT_ORCHHOME/bin
$ file osh
If the "file" command returns a 32 bit or 64 bit executable and not a script or text file, then you need to re-instate the GTK osh:
Backup the old copy of osh.exe:
mv osh.exe osh.bak
Backup the new copy of the osh executable
mv osh osh.exe
Copy the GTK script into place:
cp $GRIDHOME/osh.sh $APT_ORCHHOME/bin/osh
Now do the same for orchadmin if needed
$ file orchadmin
If the "file" command returns a 32 bit or 64 bit executable and not a script or text file, then you need to re-instate the GTK orchadmin:
Backup the old copy of orchadmin.exe:
mv orchadmin.exe orchadmin.bak
Backup the new copy of the osh executable
mv orchadmin orchadmin.exe
Copy the GTK script into place:
cp $GRIDHOME/orchadmin.sh $APT_ORCHHOME/bin/orchadmin
No need to reboot, or restart any services at this point, the fix is in place and ready to run.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21512496