Technote (troubleshooting)
Problem(Abstract)
User gets a popup dialog error when trying to login to Business Space in IBM WebSphere Business Monitor.
Symptom
You may see similar errors as follows:
BMWMB0039E:Fail to load page. The error message is: Error -
BMWMF0001E:Node must not be null. Please contact Lotus Mashups
administrator
Also
00000045 W
com.ibm.mm.server.model.persist.NLFModelPersistenceHandlerImpl loadRoot
IGNORING EXCEPTION (BMWSD0114E: Error reading a navigation tree. user
id: jbowles_user_uniqueID page id:
USER_NAVTREE_ROOT_OID000000000000000), RETURNING NULL
com.ibm.mm.framework.persistence.exceptions.DataBackendException:
BMWSD0114E: Error reading a navigation tree. user id:
jbowles_user_uniqueID page id: USER_NAVTREE_ROOT_OID000000000000000
at
com.ibm.mm.server.persistence.rdbms.dao.ibatis.NavigationDaoSqlMap.findT
opologyDescByPageAndOwner(NavigationDaoSqlMap.java:655
Cause
A possible cause is an incorrect schema name
Environment
All
Diagnosing the problem
Ensure this property is set to correct schema name:
Resource Environment > Resource Environment Provider >
Mashups_ConfigService > Custom properties
check property name schemaName value
Resolving the problem
Ensure this property is set to correct schema name:
- For a stand-alone server: profile_root\BusinessSpace\node_name\server_name\mm.runtime.prof\config\ConfigService.properties
- For a cluster: deployment_manager_profile_root\BusinessSpace\cluster_name\mm.runtime.prof\config\ConfigService.properties
- For a stand-alone server:
- For a cluster:
- Run $AdminConfig save.
Resource Environment > Resource Environment Provider >
Mashups_ConfigService > Custom properties
check property name schemaName value
If it is not correctly set then you must update the ConfigService.properties file and then run the updatePropertyConfig command to get the values changed.
| Segment | Product | Component | Platform | Version | Edition |
|---|---|---|---|---|---|
| Business Integration | IBM Business Process Manager Advanced | Business Space | AIX, Linux, Linux zSeries, Solaris, Windows, z/OS | 7.5.0.1, 7.5 | All Editions |
| Business Integration | IBM Integration Designer | Business Space | Linux, Windows | 7.5, 7.5.0.1 | All Editions |
| Business Integration | WebSphere Business Compass | Business Space | AIX, Linux, Windows | 7.0.0.4, 7.0.0.3, 7.0.0.2, 7.0.0.1, 7.0 | All Editions |
| Business Integration | WebSphere Business Modeler Publishing Server | Business Space Widgets | Linux, Windows | 7.0.0.4, 7.0.0.3, 7.0.0.2, 7.0 | |
| Business Integration | WebSphere Business Services Fabric | Business Space | AIX, Linux, Solaris, Windows | 7.0.0.3, 7.0.0.2, 7.0.0.1 | All Editions |
| Business Integration | WebSphere Process Server | Business Space | AIX, HP-UX, Linux, Solaris, Windows | 7.0.0.4, 7.0.0.3, 7.0.0.2, 7.0.0.1 | NA |
| Business Integration | WebSphere Service Registry and Repository | Business Space | AIX, HP-UX, HP Itanium, Linux, Linux pSeries, Solaris, Windows | 7.5, 7.0.0.4, 7.0.0.3, 7.0.0.2, 7.0.0.1, 7.0 | All Editions |
| Business Integration | IBM Business Monitor | Business Space | AIX, HP-UX, Linux, Solaris, Windows | 8.0, 7.5 |
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.