IBM Support

DataStage client login results in host not found error 81011

Troubleshooting


Problem

When trying to log in to DataStage using the DataStage Designer or DataStage Director client, the user receives the following error: Failed to connect to Information Server Engine: , (The host name specified is not valid, or the host is not responding (81011))

Cause

Information Server DataStage clients perform a 2-step login -- first they authenticate against the service tier (WebSphere) and if successful the client then connects to the engine tier using the hostname that was setup during DataStage install (not the host name shown in DataStage client login dialog).

Error 81011 is an engine tier error code which means the hostname specified in login dialog to access service tier worked, but that the hostname setup for DataStage engine could not be resolved.

This situation usually occurs when the user specifies a fully qualified hostname in the login dialog for service tier, i.e. myhost.mydomain.com:9080, but the DataStage engine tier is configured only with short hostname. If the fully qualified hostname is known to the network name server but the short hostname is not, then the user will receive the 81011 error when connecting to engine tier server.

The client machine needs to be able to correctly resolve the host name given in error message. If the user opens a windows command prompt and enters command:
ping hostname
using the hostname given in error message, that command will fail, and DataStage login will fail for the same reason until that short host name can be resolved.

Resolving The Problem

There are several methods to resolve this issue:

  1. Have the network administrator update the network name server to define the short hostname and the associated address. This change will then work for all users.
  2. Alternatively, you can update the DataStage client machine's tcp/ip configuration to add the domain suffix (from the fully qualified hostname that works) to the domain suffix list. When presented with any short hostname, the client machine will now attempt to convert that to fully qualified hostname by trying each defined domain suffix.
  3. Another solution for client machines is to update the hosts file on the client machine to associate the short hostname with correct machine address using the following steps:
    • First obtain address by pinging the fully qualified host name, i.e.:
      ping myhost.mydomain.com
    • Next, edit the following file:
      C:\Windows\system32\drivers\etc\hosts
    • Add the following line:
      xxx.xxx.xxx.xxx myhost myhost.mydomain.com

      Replace xxx.xxx.xxx.xxx with the address from ping command, followed by short hostname from error message and then the fully qualified hostname from login dialog.
    • After saving the change, confirm the ping command now works for short hostname. If so then DataStage client login should also work.
  4. If none of the above options are viable, you can contact the Information Server technical support team to obtain a set of instructions and scripts that are used to update the DataStage configuration to change the short hostname to the fully qualified hostname. This requires a significant amount of work to change and is usually a last resort.

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Document Information

Modified date:
16 June 2018

UID

swg21507908