What are the supported Macintosh Operating System versions for IBM SPSS Statistics 18,19, 20, 21 and 22?

Technote (FAQ)


Question

I would like to know what are the supported Macintosh Operating system versions for IBM SPSS Statistics versions 18, 19, 20, 21 and 22?

Answer

Please see the list below:

Current releases 21 and 22:

- IBM SPSS Statistics 21 release is supported on Apple Macintosh OS X 10.6 (Snow Leopard), 10.7 (Lion), and 10.8 (Mountain Lion) with Intel processor.

- IBM SPSS Statistics 22 release is supported on Apple Macintosh OS X 10.7 (Lion) and 10.8 (Mountain Lion) with Intel processor.

- IBM SPSS Statistics 22 is NOT supported for Apple Macintosh OS X 10.6 (Snow Leopard).

- Please also note: IBM SPSS Statistics 22 was developed and released prior to Apple's release of OS X 10.9 (Mavericks). However, as per SPSS Product Management Statistics 22 can be installed on Mac OSX 10.9 if you install Apple Java SE 6 (1.6.0_65) on OS X 10.9 first before you install Statistics 22. Please see http://support.apple.com/kb/dl1572 for download.

For further information on compatibility see also the IBM Software Product Compatibility Reports.

Older SPSS releases 18 to 20:

- IBM SPSS Statistics 18 and 19 releases are supported on Apple Macintosh OS 10.5 (Leopard) and 10.6 (Snow Leopard) with Intel processor.

- IBM SPSS Statistics 20 release is supported on Apple Macintosh OS X 10.6 (Snow Leopard) and 10.7 (Lion) with Intel processor.

IBM SPSS Statistics versions 18 and 19 are not supported on Mac OS 10.7 (Lion) and later.

- IBM SPSS Statistics 20 was developed and released prior to Apple's release of 10.8 (Mountain Lion) operating system. It is not formally supported on 10.8, meaning any issues found can only be addressed in future releases However, no serious issues are anticipated, and IBM SPSS Statistics 20 can run on Mountain Lion with Intel processor but:

a) for new installations of 20 it is strongly recommended to read Technote 1606447 first and follow the instructions about Apple's new Gatekeeper security feature, and

b) if you are upgrading the operating system around an existing installation of 20.0, you may experience an issue with your license code. Please see Technote 1607184 for further information.

Related information

Technote 1606447

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

SPSS Statistics

Software version:

18.0, 19.0, 20.0, 21.0, 22.0

Operating system(s):

Mac OS

Reference #:

1507587

Modified date:

2013-11-26

Translate my page

Machine Translation

Content navigation