IBM Support

(TR2934) UDA-SOR-0005 Unable to write the file.

Troubleshooting


Problem

Cube generation stops with the following error messages in the log file : RQP-DEF-0177 An error occurred while performing operation 'sqlOpenResult' status='-237'. UDA-SOR-0005 Unable to write the file. (TR3311) An error occurred during data retrieval from the database. An error occurred while sorting temporary data file.

Cause

Insufficient disk space available to create the temporary data files.

Resolving The Problem

If the Cognos Configuration interface is accessible:
- Open IBM Cognos Configuration tool
- On the left pane, select /Environnement
- On the right pane, change property "Temporary files location" to point to a disk or file system that has more free space.
- Restart Cognos services

If the Cognos Configuration interface is not available:
- Open <Cognos install root>/configuration/cogstartup.xml in a text editor, search for tag <crn:parameter name="temp"> and modify the value beneath (that is ../temp by default)
- Restart Cognos services

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Transformer","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21506970