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How do I troubleshoot Fixlet actions?

Technote (troubleshooting)


Problem(Abstract)

Steps for troubleshooting Fixlet/Task actions.

Resolving the problem

After deploying the action, the action status dialog in TEM will give you useful information in determining the cause of the failure. In the TEM Console, go to Tools --> Action Status, find the action in the action list, and click on the "View Action Info" button at the lower right hand corner. This brings up the 'View Action Info' dialog box. Below are some common messages and their cause and solution:

Status: Failed
Execution Details:
The original Fixlet message this action was intended to fix is still relevant, The action executed the following: All lines show "Completed".
Cause:
The action ran successfully but the relevance is still true for this computer.
Solution:
This may be due to the wrong matching of relevance expression to action. Make sure completion of the action will make the relevance FALSE. Please refer to the Fixlet authoring training material for more information on how to write relevance and action.

Status: Not Executed
Execution Details:
The original Fixlet message this action was intended to fix is still relevant.
Cause:
There is no relevance clause in the Fixlet message.
Solution:
If you meant the Fixlet message to always be true, simply insert a relevance expression "TRUE".

Status: Waiting
Execution Details:
Invalid action content, the action type is invalid.
Cause:
Wrong action type
Solution:
change the action type to "Windows Fixlet Shell Script."

Status: Failed
Execution Details:
The action script was not executed.
Cause:
Wrong action type.
Solution:
change the action type to "Windows Fixlet Shell Script."

Status: Error
Execution Details: There was an unknown error that occurred while processing the action.
Cause: Unknown
Solution: Unknown

For more on the different action statuses that can occur, please refer to DCF 1505986

Related information

What do the action status messages mean?

Historical Number

131

Document information

More support for: IBM BigFix family

Software version: Version Independent

Operating system(s): Platform Independent

Reference #: 1505932

Modified date: 27 January 2014


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