Traffic report portlets time-out error: DPR-ERR-2101 Your request was invalid. Please contact your administrator

Technote (troubleshooting)


Problem(Abstract)

The following error is displayed in the traffic report portlets after the browser session expires:
DPR-ERR-2101 Your request was invalid. Please contact your administrator.

Symptom

When your browser session expires while using the IBM® Traffic Information Hub version 1.0.0 solution interface, the following error is displayed in the traffic report portlets on the Traffic Operations view and the Traffic Planning view:


IBM Cognos
An error has occurred.

DPR-ERR-2101 Your request was invalid. Please contact your administrator.
Please try again or contact your administrator.

The error is still displayed after you successfully authenticate again.

This problem only occurs when using a Firefox browser on a Linux platform to access the IBM Traffic Information Hub V1.0.0 solution interface. For example, this problem can occur when you are using Firefox on Fedora or Red Hat Enterprise Linux.

Cause

The problem is caused by a browser cache issue which prevents the client from receiving an updated cookie after authentication.

Resolving the problem

This issue is fixed in the IBM Traffic Information Hub version 1.0.1.

To work around this problem in version 1.0.0, clear the cache on the browser client to remove the cookies.

Mozilla Firefox users can do this using the Clear Private Data dialog box and selecting to remove cookies. After restarting the browser, the traffic reports portlets display the expected graph reports.

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Document information


More support for:

IBM Intelligent Transportation
IBM Traffic Information Hub

Software version:

1.0.0, 1.0.1

Operating system(s):

Linux Red Hat - xSeries

Reference #:

1505501

Modified date:

2012-05-31

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