CICS Explorer for CICS TS 4.2 is compatible with earlier releases of CICS TS

Product lifecycle


Abstract

There is a new version (V1.1) of the CICS Explorer that became available with CICS Transaction Server for z/OS (CICS TS) V4.2 in June 2011. This verson is backwards compatible with CICS TS V4.1, V3.2 and V3.1. If you are running the earlier releases of CICS TS, IBM would like to encourage you to take advantage of this free update.

Content

There have been newer versions of the CICS Explorer since CICS Explorer V1.1 became available. See Latest version of CICS Explorer and CICS Tools plug-ins for CICS TS V4 or V3 for more information.

The following new functionality is available in Version 1.1.0.0 of the CICS Explorer as documented in the release notes for the CICS TS V4.2 plug-in:

  • New SM Administration perspective
  • Support for column sorting in views
  • Support for system events in the CICS event binding editor.
  • Ability to choose an EPADAPTER configuration.
  • Addition of an online and offline EP search function.
  • New edit functions added to the event binding editor.
  • Ability to create new z/OS® UNIX® directories.
  • Ability to change the access permissions for z/OS UNIX files and directories.
  • Addition of a Save as function for z/OS UNIX files.
  • Ability to create Atom configuration files.
  • Ability to disable JVM Servers.
  • Improved support for transaction tracking
  • The System z®.OS perspective is renamed to the z/OS perspective.
  • Changes to the CICS Explorer menu bar.
  • Eight new WLM views have been added in this version.
  • Four new Operations views have been added in this version.
  • Two new general views have been added in this version.
  • The Active Workloads view has been renamed to the Workloads view.
  • CICS Explorer SDK support has been added for creating Java OSGi applications

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents > What's new in version 1.1.0.0.


To get this release or any new version or release of the CICS Explorer, you must download and install it by going to the IBM CICS Explorer Downloads Web page and click on Download site. See Getting started with the CICS Explorer if you are a new to the CICS Explorer and would like more information about installation and getting updates.

If you have a copy of CICS Explorer V1.0 (pre CICS TS 4.2) on your system, you do not have to uninstall it before installing the new CICS Explorer V1.1. You can run both versions of the CICS Explorer at the same time on your system as long as you install CICS Explorer V1.1 into a different directory. Note: You should not attempt to extract over the top of an existing V1.0 installation.

Any pre V1.1 CICS Explorer workspace does not have to be deleted, and will work with the new release. However, if you install CICS Explorer V1.1 into a new directory and starts it up, you will probably be using the same workspace as the existing version of the Explorer. The only scenario under which this is not the case is if you are starting the Explorer with the -data option to specify a custom location for the CICS Explorer workspace. So, if your new and existing Explorers are sharing a workspace and the existing Explorer has some of the tools plug-ins installed into it, then you will need to reinstall the tools plug-ins into the new V1.1 Explorer that you have just installed. Otherwise when you start CICS Explorer V1.1 for the first time, you might see the message "Unable to restore perspective". The reason for this is that the workspace contains perspective configuration details for the CICS Tools previously installed, but the plug-ins have not yet been installed into the new release.

When using the same workspace, some errors might also occur for unsupported perspectives if you don't export and import your preferences, but if this occurs you can simply right click and reset the perspectives.

The latest versions of the CICS Tools plug-ins are available on the CICS Explorer download site. The versions of the CICS tools plug-ins at the time CICS Explorer V1.1 became available are:
CICS Explorer plug-in for CICS Configuration Manager V2.1.0.9
CICS Explorer plug-in for CICS Deployment Assistant V1.1.0.2
CICS Explorer plug-in for CICS Interdependency Analyzer V3.1.0.9*
CICS Explorer plug-in for CICS Performance Analyzer V3.2.0.1
CICS Explorer plug-in for IBM Session Manager V3.1.0.0*

Explorer V1.1 is based on a newer version of Eclipse (V3.6) than the Explorer V1.0 is based on Eclipse V3.4.. This new Eclipse means that the way of installing the tools plug-ins has changed. Rather than clicking Help > Software Updates, you now click Help > Install New Software.

To install the CICS Tools plug-ins in the new Explorer:
  1. Download the tools plug-in. Do not unpack the file.
  2. On the CICS Explorer menu bar click Help > Install new Software.
  3. Click Add to add a new repository, then click *Archive*.
  4. Locate and select the tools plug-in previously downloaded and click Open.
  5. Click OK. When you click OK, if you are installing the latest version of the plug-in, the plug-in name is displayed. If you are installing a previous version of the plug-in you must deselect the "Group items by category" checkbox to display the plug-in details.
  6. Select the plug-in(s) to install and click Next.
  7. Continue as prompted.

If you see the message "Duplicate location" during step 4, that can mean one of two things:
  • If this is the first time you have attempted to install this plug-in in CICS Explorer V1.1, the message suggests that you did not install CICS Explorer in an empty directory, and some residual information remains from a previous installation. If this is the case, you should re-install CICS Explorer in a clean directory.
  • You have previously installed, or prepared to install, the plug-in at this location, and CICS Explorer has saved the location details. If this is the case, cancel the "Add Repository" dialog. In the Available Software view, click the "Work with" twistie and select the location containing the plug-in you want to install, then continue with the next step.

For more information about installing the tools plug-ins, see CICS Explorer 1.1 - getting APA, CTG, FM, FA, IA and other uncategorized plugins to install.

Related information

Announcement letter for CICS TS V4.2
Webinar: What is new in CICS Explorer 1.1.0.0

Cross reference information
Segment Product Component Platform Version Edition
Host Transaction Processing CICS Configuration Manager for z/OS CICS Explorer Plug-in z/OS 2.1, 1.2
Host Transaction Processing CICS Deployment Assistant for z/OS Explorer Plug-in z/OS, Linux, Windows 1.1
Host Transaction Processing CICS Interdependency Analyzer for z/OS Eclipse plugin z/OS 2.2, 3.1
Host Transaction Processing CICS Performance Analyzer for z/OS CICS Explorer Plug-in z/OS 3.1, 3.2
Host Transaction Processing IBM Session Manager z/OS 3.1

Product Alias/Synonym

CICS/TS CICS TS CICS Transaction Server

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

CICS Transaction Server
Explorer

Software version:

3.1, 3.2, 4.1, 4.2

Operating system(s):

z/OS

Software edition:

Not Applicable

Reference #:

1504423

Modified date:

2012-05-25

Translate my page

Machine Translation

Content navigation